summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/vcr
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/vcr')
-rw-r--r--dev-ruby/vcr/Manifest2
-rw-r--r--dev-ruby/vcr/metadata.xml8
-rw-r--r--dev-ruby/vcr/vcr-1.11.3.ebuild23
-rw-r--r--dev-ruby/vcr/vcr-2.9.3.ebuild23
4 files changed, 56 insertions, 0 deletions
diff --git a/dev-ruby/vcr/Manifest b/dev-ruby/vcr/Manifest
new file mode 100644
index 000000000000..93467a254031
--- /dev/null
+++ b/dev-ruby/vcr/Manifest
@@ -0,0 +1,2 @@
+DIST vcr-1.11.3.gem 87552 SHA256 6dcdd782d631b1464192d47db2a5a86d2325c80a723a4b2970f47da98f006f1d SHA512 0d62b0699e42484a4ba385a2ec653881183b44d85fd46ffc1ea693ebb746b225566cdb2799cdb60235c24adecd7575e0f20d743968326eeeb5b24fbd3232354a WHIRLPOOL f2c91385bc6dd68340f1a4960f3ec4944afd1907d33c8163ebe99d1e72c5b0f45e665463161654d4a330d2cfad25674b8a8e97a3cf2e1ae309d7ae6c4fd2be09
+DIST vcr-2.9.3.gem 152576 SHA256 041361620a613e18c514b5e680bfbed3a8db69e1ffe5916957ba36966dd92190 SHA512 2d71a84439fb92393641d211372b476bb2b55c70dff8c8f17a4af9fcb3e8f9104e1da860cfeafc8ceea9499023c7f6206124dee36ee9690188cc444bab61b2a7 WHIRLPOOL 0994aab3f00da3c628fe1ad5e752bc694b6096ace92edeb1d3f5877864a80ffdd4c3d1ce69d0119ca91dae8d72a6172de1901ab4db1c27750bf83f25825c0052
diff --git a/dev-ruby/vcr/metadata.xml b/dev-ruby/vcr/metadata.xml
new file mode 100644
index 000000000000..7a07c25b066b
--- /dev/null
+++ b/dev-ruby/vcr/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">myronmarston/vcr</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/vcr/vcr-1.11.3.ebuild b/dev-ruby/vcr/vcr-1.11.3.ebuild
new file mode 100644
index 000000000000..42c5203f5b9a
--- /dev/null
+++ b/dev-ruby/vcr/vcr-1.11.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Records your test suite's HTTP interactions and replay them during future test runs."
+HOMEPAGE="https://github.com/myronmarston/vcr/"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="1"
+IUSE="test"
+
+# Tests require all supported HTTP libraries to be present, and it is
+# not possible to avoid some of them without very extensive patches.
+RESTRICT="test"
diff --git a/dev-ruby/vcr/vcr-2.9.3.ebuild b/dev-ruby/vcr/vcr-2.9.3.ebuild
new file mode 100644
index 000000000000..ebcd708076a1
--- /dev/null
+++ b/dev-ruby/vcr/vcr-2.9.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md CONTRIBUTING.md README.md Upgrade.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Records your test suite's HTTP interactions and replay them during future test runs."
+HOMEPAGE="https://github.com/myronmarston/vcr/"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="2"
+IUSE="test"
+
+# Tests require all supported HTTP libraries to be present, and it is
+# not possible to avoid some of them without very extensive patches.
+RESTRICT="test"