summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-03-01 07:20:26 +0100
committerHans de Graaff <graaff@gentoo.org>2024-03-01 07:20:26 +0100
commitcdadbe9b630eeba76d57e8e3760e4e02f4af9668 (patch)
tree1646d331ff12010852237d88d69eeed8ed8bdec4 /dev-ruby/yard
parentdev-ruby/drb: add 2.2.1 (diff)
downloadgentoo-cdadbe9b630eeba76d57e8e3760e4e02f4af9668.tar.gz
gentoo-cdadbe9b630eeba76d57e8e3760e4e02f4af9668.tar.bz2
gentoo-cdadbe9b630eeba76d57e8e3760e4e02f4af9668.zip
dev-ruby/yard: add 0.9.36
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/yard')
-rw-r--r--dev-ruby/yard/Manifest1
-rw-r--r--dev-ruby/yard/yard-0.9.36.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-ruby/yard/Manifest b/dev-ruby/yard/Manifest
index 915ffbb319ff..4da78ffc6173 100644
--- a/dev-ruby/yard/Manifest
+++ b/dev-ruby/yard/Manifest
@@ -3,3 +3,4 @@ DIST yard-0.9.34-git.tgz 938057 BLAKE2B 0e5b96b29efc6b7ab6c52dc34a15d4df9b614eb5
DIST yard-0.9.34-yield-ruby33.patch 920 BLAKE2B a0492919b8038c21c109732aa12afa4d494ceacf6ff5e2c8fbae56bc279b5e9c6a951f77144d069183d7dc9ad818066aab5c4d82c4dc39c31a48272dad6a0d0b SHA512 86bd7d2b8ccfccc73a46365b0814c0d741bde8508317856d80ae6a2cccff1a338ad9754afd21f8f64d2587195f8cc3f38b6eba78e8de1d729ac3b2141bdb124a
DIST yard-0.9.35-git.tgz 938495 BLAKE2B 27e8c0e576f5150d1adcfd63afdfcb33f437319ae646347c8b0ab24e6b093b4d3de3f0703cc0683a420e93f8d6261c2221d0af7c3ed6dfe463d2f296bdfeda49 SHA512 83251d52b8f4ec00411cb223386b9b3763da530c37db7a99a9a3747139b97f52d4e978e7556c3d50896537ad60a89d88b67affc630d4f7617062c33e6ec223ac
DIST yard-0.9.35-yield-ruby33.patch 920 BLAKE2B a0492919b8038c21c109732aa12afa4d494ceacf6ff5e2c8fbae56bc279b5e9c6a951f77144d069183d7dc9ad818066aab5c4d82c4dc39c31a48272dad6a0d0b SHA512 86bd7d2b8ccfccc73a46365b0814c0d741bde8508317856d80ae6a2cccff1a338ad9754afd21f8f64d2587195f8cc3f38b6eba78e8de1d729ac3b2141bdb124a
+DIST yard-0.9.36-git.tgz 938567 BLAKE2B 8672b94149b4bbecd3fb80c1d386e3cdfd4013ad88969958269abd480426e41990067df0e5352df1a983a1572129b91a31129a71eae872cc00712e6e992a07c5 SHA512 09639d7ac6fed28906b40e08c16e305f44416206f67947fbdedf4adbb0be92d1e15ade9a04509f2847063b39baaa7a5bcbd585031808baaaf5acf14f06b471d5
diff --git a/dev-ruby/yard/yard-0.9.36.ebuild b/dev-ruby/yard/yard-0.9.36.ebuild
new file mode 100644
index 000000000000..5d1f8575ffe4
--- /dev/null
+++ b/dev-ruby/yard/yard-0.9.36.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC="yard"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_DOCDIR="doc docs"
+
+RUBY_FAKEGEM_EXTRAINSTALL="templates .yardopts"
+
+RUBY_FAKEGEM_GEMSPEC="yard.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Documentation generation tool for the Ruby programming language"
+HOMEPAGE="https://yardoc.org/"
+
+# The gem lacks the gemspec file needed to pass tests.
+SRC_URI="https://github.com/lsegal/yard/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.9.34-beginless-range.patch"
+)
+
+ruby_add_bdepend "doc? ( || ( dev-ruby/maruku dev-ruby/rdiscount dev-ruby/kramdown ) )"
+
+ruby_add_bdepend "test? ( dev-ruby/rack:2.2 >=dev-ruby/rspec-3.11.0 dev-ruby/webrick )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/ s:^:#:' -e '3igem "rack", "~> 2.2.0"' spec/spec_helper.rb || die
+
+ sed -i -e '/samus/I s:^:#:' Rakefile || die
+
+ sed -i -e 's/git ls-files/find/' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid specs that make assumptions on load ordering that are not
+ # true for us. This may be related to how we install in Gentoo. This
+ # also drops a test requirement on dev-ruby/rack.
+ rm -f spec/cli/server_spec.rb || die
+
+ # Avoid specs that only work with bundler
+ sed -i -e '/#initialize/,/^ end/ s:^:#:' spec/cli/yri_spec.rb || die
+ sed -e '/overwrites options with data in/askip "wrong assumptions on file access"' \
+ -e '/loads any gem plugins starting with/askip "wrong assumptions on file access"' \
+ -i spec/config_spec.rb || die
+
+ # Avoid specs making assumptions about how rubygems works internally
+ sed -i -e '/searches for .gem file/askip "rubygems internals"' spec/cli/diff_spec.rb || die
+
+ # Fix broken spec
+ sed -i -e '/:exist?/aallow(File).to receive(:exist?).and_call_original' spec/i18n/locale_spec.rb || die
+
+ # Avoid ruby31 failure on whitespace-only differences
+ sed -i -e '/shows a list of nodes/askip "Whitespace differences on ruby31"' spec/parser/ruby/ast_node_spec.rb || die
+
+ # Avoid redcarpet-specific spec that is not optional
+ sed -i -e '/autolinks URLs/askip "make redcarpet optional"' spec/templates/helpers/html_helper_spec.rb || die
+
+ # Avoid asciidoc-specific spec that is not optional
+ sed -e '/\(AsciiDoc specific\|AsciiDoc header\)/askip "skipping asciidoc test"' \
+ -i spec/templates/helpers/html_helper_spec.rb || die
+}