summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-09-23 14:18:32 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2022-09-23 14:18:32 -0500
commit225e672c864e87b634c2a345c6f8ffc9460f2908 (patch)
treed2ec20ce0ef1c6450099287c4545f273824ad7ce /dev-ruby
parentdev-util/android-tools: add 33.0.3 (diff)
downloadgentoo-225e672c864e87b634c2a345c6f8ffc9460f2908.tar.gz
gentoo-225e672c864e87b634c2a345c6f8ffc9460f2908.tar.bz2
gentoo-225e672c864e87b634c2a345c6f8ffc9460f2908.zip
dev-ruby/facter: drop 3.14.23
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/facter/Manifest1
-rw-r--r--dev-ruby/facter/facter-3.14.23.ebuild100
2 files changed, 0 insertions, 101 deletions
diff --git a/dev-ruby/facter/Manifest b/dev-ruby/facter/Manifest
index c8722b714e98..134c21ca499e 100644
--- a/dev-ruby/facter/Manifest
+++ b/dev-ruby/facter/Manifest
@@ -1,2 +1 @@
-DIST facter-3.14.23.tar.gz 410645 BLAKE2B 7455435d1ab1b1f6e97996aa54be57321bbe0e294652b1aebe0e1ee0e7be45309c1a89fae4079a4350fd6e689c0fe782a7f5d3eee3d766842fba1e8b70a702b7 SHA512 be207d37cf5eac4b6b95cb13e8c2598ccc03af3bcbeedb0d814e5c11c43eb7579427fa1fc1a29eb6db4d6c43b19b2c87c88bd0c85ac3550fa886753267626986
DIST facter-3.14.24.tar.gz 410547 BLAKE2B 69d2fd3b1bf9f91456ca570f9fef44ddd6e7656a285c035ecb42df2553c461be137d06232fc1f96f239598143912928dcfaf0d9b3078f4335dfc83163eee5120 SHA512 88e47271f213570fb7819630f7b08076bd8b234612a2bb885de760acab48c37b588c1f214da11c5096f0db6b7df4a516b6e83abc56a1d95779b6f1353831e588
diff --git a/dev-ruby/facter/facter-3.14.23.ebuild b/dev-ruby/facter/facter-3.14.23.ebuild
deleted file mode 100644
index 0eeddc26c2f1..000000000000
--- a/dev-ruby/facter/facter-3.14.23.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-# git-r3 goes after ruby-ng so that it overrides src_unpack properly
-inherit cmake eutils ruby-ng
-
-DESCRIPTION="A cross-platform ruby library for retrieving facts from operating systems"
-HOMEPAGE="http://www.puppetlabs.com/puppet/related-projects/facter/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="test"
-if [[ ${PV} == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/puppetlabs/facter.git"
- EGIT_BRANCH="master"
-else
- [[ "${PV}" = *_rc* ]] || \
- KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc x86"
- SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-fi
-
-RESTRICT="!test? ( test )"
-
-ruby_add_bdepend "test? ( dev-ruby/rake dev-ruby/rspec:2 dev-ruby/mocha:0.14 )"
-
-RDEPEND="
- >=dev-cpp/cpp-hocon-0.2.1:=
- >=dev-libs/leatherman-1.0.0:=
- dev-libs/openssl:0=
- sys-apps/util-linux
- app-emulation/virt-what
- net-misc/curl
- dev-libs/boost:=[nls]
- >=dev-cpp/yaml-cpp-0.5.1
- !<app-admin/puppet-4.0.0"
-DEPEND="${RDEPEND}"
-
-# restore ${S} and override all phases exported by ruby-ng.eclass
-S="${WORKDIR}/${P}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.14.6-fix-static-libcpp-hocon.patch
- # be explicit about the version of rspec we test with
- "${FILESDIR}"/${PN}-3.14.8-explicit-rspec-2.patch
- "${FILESDIR}"/${PN}-3.14.23-gcc12.patch
-)
-
-pkg_setup() {
- ruby-ng_pkg_setup
-}
-
-src_unpack() {
- default
-
- if [[ ${PV} == 9999 ]] ; then
- git-r3_src_unpack
- fi
-}
-
-src_prepare() {
- cmake_src_prepare
-}
-
-each_ruby_configure() {
- # hack for correct calculation of relative path from facter.rb to
- # libfacter.so
- my_ruby_sitelibdir=$(ruby_rbconfig_value 'sitelibdir')
-}
-
-src_configure() {
- ruby-ng_src_configure
-
- local mycmakeargs=(
- -DRUBY_LIB_INSTALL=${my_ruby_sitelibdir}
- -DBLKID_LIBRARYDIR="${EPREFIX}/$(get_libdir)"
- )
- cmake_src_configure
-}
-
-src_compile() {
- addpredict /proc/self/oom_score_adj
- cmake_src_compile
-}
-
-src_test() {
- cmake_src_test
-}
-
-each_ruby_install() {
- doruby "${BUILD_DIR}"/lib/facter.rb
-}
-
-src_install() {
- cmake_src_install
- ruby-ng_src_install
-}