summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-08-18 09:24:13 +0200
committerHans de Graaff <graaff@gentoo.org>2024-08-18 09:24:13 +0200
commit23d1bb5810034e56ef35136400b38ff4979aed98 (patch)
tree8a49073bc1d65622c3271c8f5ccacfe2a409b6d4 /dev-ruby
parentdev-ruby/pg: add 1.5.7 (diff)
downloadgentoo-23d1bb5810034e56ef35136400b38ff4979aed98.tar.gz
gentoo-23d1bb5810034e56ef35136400b38ff4979aed98.tar.bz2
gentoo-23d1bb5810034e56ef35136400b38ff4979aed98.zip
dev-ruby/propshaft: add 0.9.1
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/propshaft/Manifest1
-rw-r--r--dev-ruby/propshaft/propshaft-0.9.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/propshaft/Manifest b/dev-ruby/propshaft/Manifest
index af2c9a79148a..504e387dddb4 100644
--- a/dev-ruby/propshaft/Manifest
+++ b/dev-ruby/propshaft/Manifest
@@ -1,2 +1,3 @@
DIST propshaft-0.8.0-git.tgz 247518 BLAKE2B fe57104a1abd683d74a3166931256f2cdc8e942fffe80c286acfc6db6fa105810bc929f03dd959a660835f030acb580dbd18e7b20f16cfb168b0953731bb2f90 SHA512 3a40355063edb912107ec27ac43ba76746bbd04da04096a4480b43f6fd103bfaec53957d1bbc2bf3d0e08237d965af4d3bf8067b558c4e417ffb506a84f1abff
DIST propshaft-0.9.0-git.tgz 250362 BLAKE2B c90f2d552769a394650511d4453c7c12771d3b48841418b83e876bafd41d95f40c477262adc57068c490ad1d08de68aa26fcf807c48d9af5fc8decb4b4f255ed SHA512 26e7336bb998b83f33243d6ecd03fd8b1307c0dedf2f9ad5a9333fba43cc4bfec93ded0b9ed825e633cde1d5451db6d87fb51c840b26456687462caa8adddee7
+DIST propshaft-0.9.1-git.tgz 250403 BLAKE2B 194dad0d196421c71220a47e66ebd36d744f8009551c210244a1f7a79a04d095fe4b00497c8dcf4b57358c9454768cae3d6743855b5f0a59a6ead0d282938a55 SHA512 5d2d707f00b09c89c01d217695a7bd7a44f2427df091e84883f07e01b821218bd16776196c6f468071fc95a211df785443f12da0f795d433e359e1655f08c4ce
diff --git a/dev-ruby/propshaft/propshaft-0.9.1.ebuild b/dev-ruby/propshaft/propshaft-0.9.1.ebuild
new file mode 100644
index 000000000000..2c71d628a3fb
--- /dev/null
+++ b/dev-ruby/propshaft/propshaft-0.9.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="propshaft.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Deliver assets for Rails"
+HOMEPAGE="https://github.com/rails/propshaft"
+SRC_URI="https://github.com/rails/propshaft/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+IUSE="test"
+
+ruby_add_rdepend "
+ >=dev-ruby/actionpack-7.0.0:*
+ >=dev-ruby/activesupport-7.0.0:*
+ dev-ruby/rack:*
+ >=dev-ruby/railties-7.0.0:*
+"
+
+ruby_add_bdepend "test? ( >=dev-ruby/rails-7.0.0 )"
+
+all_ruby_prepare() {
+ rm -f Gemfile.lock || die
+ sed -i -e '/debug/ s:^:#:' Gemfile || die
+
+ sed -i -e 's:_relative ": "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
+}