summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-10-26 10:14:10 +0200
committerHans de Graaff <graaff@gentoo.org>2024-10-26 10:16:25 +0200
commit33013fd49df68cd204ba423b7a1207b94e491b17 (patch)
treee45468c31ea5176ab39dee076708f1e6925e6a9a /dev-ruby
parentdev-ruby/activestorage: add 6.1.7.10 (diff)
downloadgentoo-33013fd49df68cd204ba423b7a1207b94e491b17.tar.gz
gentoo-33013fd49df68cd204ba423b7a1207b94e491b17.tar.bz2
gentoo-33013fd49df68cd204ba423b7a1207b94e491b17.zip
dev-ruby/actionmailbox: add 6.1.7.10
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/actionmailbox/Manifest1
-rw-r--r--dev-ruby/actionmailbox/actionmailbox-6.1.7.10.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-ruby/actionmailbox/Manifest b/dev-ruby/actionmailbox/Manifest
index 4086f4650837..046023b83751 100644
--- a/dev-ruby/actionmailbox/Manifest
+++ b/dev-ruby/actionmailbox/Manifest
@@ -1,3 +1,4 @@
+DIST rails-6.1.7.10.tgz 11034185 BLAKE2B 569fcde5a788151af1eb1bfe7a83048e92bdca36a3e219848567aec47877d17d791ba9f5e4913e077d458e52e7a6b69d448e1763b68e8284b9de4d2a60feaaab SHA512 ae601abca73cb6b962a9863fece1bca2e9ab64ef884054df58ec51cbc8256e9dc26086ade7c0c24c37a2047fd9f21f121ac22b44384bcd877df1d300aa06fe79
DIST rails-6.1.7.8.tgz 11041890 BLAKE2B 285571972ec1d43ae65f3c4f586679e31d0550263c4778925c5828000d6ba971a791ad1071a7ab5edd8d728cd51ee15bb5cee1261b828a4b5926a54f34887d10 SHA512 8c819da0f46820f05d4128444fb3c3908d5e50f97935b173cdd156a986720dda6bcbb62015884d3142ebd5b17621e3f94ca2c80691564914088e884b9aac3573
DIST rails-6.1.7.9.tgz 11034686 BLAKE2B 12edf62a94e0b504f1db721081ce35a6b7e8f67bded2801ce54872f7cef80fb75120f56b356940a44d943cbd05b4d63778726885ac20dd04a2e5510f54ea06ac SHA512 387cbc5424b16ade97091e3cfc3a5bc0cfe277ee75a7f35cdf5d393c692d2ea17f258e38d8b25c8c8a1be4fb64a39d0f675b23942145929bb7be4783cd95d90b
DIST rails-7.0.8.4.tgz 11082427 BLAKE2B 2ca521ad92b7a33fa2160b4cfbc1aac826641d2aac7a8751b6acaed1b7fc42bb860b4ade3f973eb51dc17d20fa4c97b02e8d6b970ae63b042cd58ab2f6cfc797 SHA512 e6628e901fcdcd4b9101cdae0cd556569fc7b577466a15f99d1e221c1c0059287dce87c1362df8b23ded992e96c551b35c0c789e683f080079e678555b7a79e6
diff --git a/dev-ruby/actionmailbox/actionmailbox-6.1.7.10.ebuild b/dev-ruby/actionmailbox/actionmailbox-6.1.7.10.ebuild
new file mode 100644
index 000000000000..26ec21f10812
--- /dev/null
+++ b/dev-ruby/actionmailbox/actionmailbox-6.1.7.10.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="actionmailbox.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRAINSTALL="app config db"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="test"
+
+RUBY_S="rails-${PV}/${PN}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.1.7.4-mail28.patch
+)
+
+ruby_add_rdepend "
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/activejob-${PV}
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/activestorage-${PV}
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/mail-2.7.1:*
+"
+
+ruby_add_bdepend "test? (
+ dev-ruby/bundler
+ <dev-ruby/minitest-5.16
+ dev-ruby/mocha
+ dev-ruby/rexml
+ dev-ruby/sqlite3
+ dev-ruby/webmock
+ dev-ruby/rails
+)"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|mysql2\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|sass-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|sprockets\|stackprof\|websocket-client-simple\|libxml-ruby\|redis\|blade\|aws-sdk\|google-cloud\|azure-storage\|selenium\|webdrivers\|webrick\|minitest-bisect\|minitest-retry\|minitest-reporters\|listen\|rack-cache\|rack-test\|capybara\|webpacker\|bootsnap\|dalli\|connection_pool\)/ s:^:#:" \
+ -e '/group :\(cable\|doc\|job\|rubocop\|storage\|test\)/,/^end/ s:^:#:' \
+ -i ../Gemfile || die
+ rm ../Gemfile.lock || die
+ sed -i -e '/byebug/ s:^:#:' test/test_helper.rb || die
+
+ # Avoid a test failing because the actionmailer part of the tarball
+ # is not patched for ruby32. Fixed in next upstream release.
+ rm -f test/unit/mailbox/bouncing_test.rb || die
+}
+
+each_ruby_prepare() {
+ sed -i -e 's:ruby:'${RUBY}':' test/dummy/bin/* || die
+}