summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-01-01 09:15:10 +0100
committerHans de Graaff <graaff@gentoo.org>2024-01-01 10:32:09 +0100
commit41e93b8832105e8962f295a109cbaf0b75b572f9 (patch)
tree18c99e7bcb09f45e471e99a01472c1d4541f40fa /dev-ruby
parentdev-ruby/puppet-resource_api: add 1.9.0 (diff)
downloadgentoo-41e93b8832105e8962f295a109cbaf0b75b572f9.tar.gz
gentoo-41e93b8832105e8962f295a109cbaf0b75b572f9.tar.bz2
gentoo-41e93b8832105e8962f295a109cbaf0b75b572f9.zip
dev-ruby/pastel: update EAPI 7 -> 8
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/pastel/pastel-0.8.0-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/pastel/pastel-0.8.0-r1.ebuild b/dev-ruby/pastel/pastel-0.8.0-r1.ebuild
new file mode 100644
index 000000000000..372c20ae05ff
--- /dev/null
+++ b/dev-ruby/pastel/pastel-0.8.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="pastel.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Terminal strings styling with intuitive and clean API"
+HOMEPAGE="https://github.com/piotrmurach/pastel"
+SRC_URI="https://github.com/piotrmurach/pastel/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/tty-color-0.5:0
+"
+
+all_ruby_prepare() {
+ echo '-rspec_helper' > .rspec || die
+ sed -i -e 's:_relative ": "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
+}