summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-11-03 08:11:49 +0100
committerHans de Graaff <graaff@gentoo.org>2024-11-03 08:11:49 +0100
commitc7bb1130627436b4fa35a0ce3d812aa067553529 (patch)
treecf40d10732621e65d73474a9277fc5e9d5b8989d /dev-ruby
parentdev-ruby/sprockets: drop 4.2.0-r1 (diff)
downloadgentoo-c7bb1130627436b4fa35a0ce3d812aa067553529.tar.gz
gentoo-c7bb1130627436b4fa35a0ce3d812aa067553529.tar.bz2
gentoo-c7bb1130627436b4fa35a0ce3d812aa067553529.zip
dev-ruby/shoulda-context: drop 2.0.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/shoulda-context/shoulda-context-2.0.0.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-ruby/shoulda-context/shoulda-context-2.0.0.ebuild b/dev-ruby/shoulda-context/shoulda-context-2.0.0.ebuild
deleted file mode 100644
index 5a6a7399f6e7..000000000000
--- a/dev-ruby/shoulda-context/shoulda-context-2.0.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-USE_RUBY="ruby30 ruby31 ruby32"
-
-RUBY_FAKEGEM_EXTRADOC="CONTRIBUTING.md README.md"
-
-RUBY_FAKEGEM_EXTRAINSTALL="tasks"
-
-# Don't install the conversion script to avoid collisions with older
-# shoulda.
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem
-
-DESCRIPTION="Context framework extracted from Shoulda"
-HOMEPAGE="https://github.com/thoughtbot/shoulda-context"
-
-LICENSE="MIT"
-SLOT="$(ver_cut 1)"
-KEYWORDS="amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="doc test"
-
-ruby_add_bdepend "test? ( dev-ruby/test-unit:2
- >=dev-ruby/mocha-1.0 )"
-
-all_ruby_prepare() {
- sed -e '/\(current_bundle\|CurrentBundle\)/ s:^:#:' \
- -e '/pry-byebug/ s:^:#:' \
- -e '/warnings_logger/ s:^:#: ; /WarningsLogger/,/^)/ s:^:#:' \
- -e '/rails_application_with_shoulda_context/ s:^:#:' \
- -i test/test_helper.rb || die
- rm -f test/shoulda/{railtie,rerun_snippet,test_framework_detection}_test.rb || die
-}
-
-each_ruby_test() {
- ${RUBY} -Ilib:test:. -e 'Dir["test/shoulda/*_test.rb"].each { require _1 }' || die
-}