summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-11-30 13:45:47 +0000
committerSam James <sam@gentoo.org>2024-11-30 13:51:15 +0000
commit2e245ec12e6cd2fc1b28087224d9b98224aab8cf (patch)
tree0117e7839464f272f39752846a57ff6737229fc9 /dev-scheme
parentdev-scheme/guile-json: drop 4.7.3 (diff)
downloadgentoo-2e245ec12e6cd2fc1b28087224d9b98224aab8cf.tar.gz
gentoo-2e245ec12e6cd2fc1b28087224d9b98224aab8cf.tar.bz2
gentoo-2e245ec12e6cd2fc1b28087224d9b98224aab8cf.zip
dev-scheme/guile-libyaml: drop 20211124
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-scheme')
-rw-r--r--dev-scheme/guile-libyaml/guile-libyaml-20211124.ebuild68
1 files changed, 0 insertions, 68 deletions
diff --git a/dev-scheme/guile-libyaml/guile-libyaml-20211124.ebuild b/dev-scheme/guile-libyaml/guile-libyaml-20211124.ebuild
deleted file mode 100644
index 8801a5f484a3..000000000000
--- a/dev-scheme/guile-libyaml/guile-libyaml-20211124.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-[[ ${PV} == 20211124 ]] && COMMIT=2bdacb72a65ab63264b2edc9dac9692df7ec9b3e
-
-DESCRIPTION="Simple yaml module for Guile using the ffi-helper from nyacc"
-HOMEPAGE="https://github.com/mwette/guile-libyaml/"
-SRC_URI="https://github.com/mwette/${PN}/archive/${COMMIT}.tar.gz
- -> ${P}.tar.gz"
-S="${WORKDIR}"/${PN}-${COMMIT}
-
-LICENSE="LGPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- >=dev-scheme/guile-2.0.0:=
- dev-libs/libyaml
-"
-DEPEND="${RDEPEND}"
-BDEPEND="dev-scheme/guile-nyacc"
-
-# guile generates ELF files without use of C or machine code
-# It's a portage's false positive. bug #677600
-QA_PREBUILT='*[.]go'
-
-guild_local() {
- GUILE_LOAD_COMPILED_PATH="${S}" GUILE_LOAD_PATH="${S}" guild "${@}" || die
-}
-
-src_prepare() {
- default
-
- # http://debbugs.gnu.org/cgi/bugreport.cgi?bug=38112
- find "${S}" -name "*.scm" -exec touch {} + || die
-}
-
-src_compile() {
- # Generate bindings using NYACC
- guild_local compile-ffi --no-exec yaml/libyaml.ffi
-
- # Compile modules
- mkdir -p "${S}"/ccache || die
- guild_local compile -o "${S}"/ccache/libyaml.go "${S}"/yaml/libyaml.scm
- guild_local compile -o "${S}"/ccache/yaml.go "${S}"/yaml.scm
-}
-
-src_install() {
- local site_dir="$(guile -c '(display (%site-dir))')"
- insinto "${site_dir}"/yaml
- doins yaml/libyaml.scm
- insinto "${site_dir}"
- doins yaml.scm
-
- local site_ccache_dir="$(guile -c '(display (%site-ccache-dir))')"
- insinto "${site_ccache_dir}"/yaml
- doins ccache/libyaml.go
- insinto "${site_ccache_dir}"
- doins ccache/yaml.go
-
- einstalldocs
-
- # Workaround llvm-strip problem of mangling guile ELF debug
- # sections: https://bugs.gentoo.org/905898
- dostrip -x "/usr/$(get_libdir)/guile"
-}