summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/automoc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/automoc')
-rw-r--r--dev-util/automoc/Manifest1
-rw-r--r--dev-util/automoc/automoc-0.9.88-r1.ebuild35
-rw-r--r--dev-util/automoc/files/automoc-0.9.88-objc++.patch48
-rw-r--r--dev-util/automoc/metadata.xml5
4 files changed, 89 insertions, 0 deletions
diff --git a/dev-util/automoc/Manifest b/dev-util/automoc/Manifest
new file mode 100644
index 000000000000..b884d4973936
--- /dev/null
+++ b/dev-util/automoc/Manifest
@@ -0,0 +1 @@
+DIST automoc4-0.9.88.tar.bz2 9153 SHA256 234116f4c05ae21d828594d652b4c4a052ef75727e2d8a4f3a4fb605de9e4c49 SHA512 96dfa096a3793f93f6a4acf98c051c871c0285124bff09b12914a17e08a1f26cd63f0bb1c22fdf2c5c29550a1727a087b5de86bfa8a555c562e96052b4a2d820 WHIRLPOOL b66cdf3e04f825bacbdab7b5e6206db4979f3a8625bdb8e86f64b61fdc1e9cfe3e18a151d61ceb3e8b7b2dac5878dd9ee9de4e3b265326f496e781f8f18ac0ef
diff --git a/dev-util/automoc/automoc-0.9.88-r1.ebuild b/dev-util/automoc/automoc-0.9.88-r1.ebuild
new file mode 100644
index 000000000000..c6d70717acf4
--- /dev/null
+++ b/dev-util/automoc/automoc-0.9.88-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_PN="automoc4"
+MY_P="${MY_PN}-${PV}"
+inherit cmake-utils flag-o-matic
+
+DESCRIPTION="KDE Meta Object Compiler"
+HOMEPAGE="http://www.kde.org"
+SRC_URI="mirror://kde/stable/${MY_PN}/${PV}/${MY_P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:4
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=( "${FILESDIR}/${PN}-0.9.88-objc++.patch" )
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ if [[ ${ELIBC} = uclibc ]]; then
+ append-flags -pthread
+ fi
+}
diff --git a/dev-util/automoc/files/automoc-0.9.88-objc++.patch b/dev-util/automoc/files/automoc-0.9.88-objc++.patch
new file mode 100644
index 000000000000..1f4dacdc06eb
--- /dev/null
+++ b/dev-util/automoc/files/automoc-0.9.88-objc++.patch
@@ -0,0 +1,48 @@
+Please refer to
+ http://websvn.kde.org/?view=revision&revision=934696
+
+Adds support for objc++ in automoc, so that running moc on .mm-files will work.
+
+--- trunk/kdesupport/automoc/Automoc4Config.cmake 2009/03/03 15:40:57 934695
++++ trunk/kdesupport/automoc/Automoc4Config.cmake 2009/03/03 15:42:18 934696
+@@ -105,9 +105,9 @@
+ if(NOT _generated AND NOT _skip)
+ get_filename_component(_suffix "${_current_FILE}" EXT)
+ # skip every source file that's not C++
+- if(_suffix STREQUAL ".cpp" OR _suffix STREQUAL ".cc" OR _suffix STREQUAL ".cxx" OR _suffix STREQUAL ".C")
++ if(_suffix STREQUAL ".cpp" OR _suffix STREQUAL ".cc" OR _suffix STREQUAL ".cxx" OR _suffix STREQUAL ".C" OR _suffix STREQUAL ".mm")
+ list(APPEND _moc_files ${_abs_current_FILE})
+- endif(_suffix STREQUAL ".cpp" OR _suffix STREQUAL ".cc" OR _suffix STREQUAL ".cxx" OR _suffix STREQUAL ".C")
++ endif(_suffix STREQUAL ".cpp" OR _suffix STREQUAL ".cc" OR _suffix STREQUAL ".cxx" OR _suffix STREQUAL ".C" OR _suffix STREQUAL ".mm")
+ endif(NOT _generated AND NOT _skip)
+ endforeach (_current_FILE)
+
+@@ -156,7 +156,7 @@
+ if(NOT _generated AND NOT _skip)
+ get_filename_component(_suffix "${_current_FILE}" EXT)
+ # skip every source file that's not C++
+- if(_suffix STREQUAL ".cpp" OR _suffix STREQUAL ".cc" OR _suffix STREQUAL ".cxx" OR _suffix STREQUAL ".C")
++ if(_suffix STREQUAL ".cpp" OR _suffix STREQUAL ".cc" OR _suffix STREQUAL ".cxx" OR _suffix STREQUAL ".C" OR _suffix STREQUAL ".mm")
+ get_filename_component(_basename "${_current_FILE}" NAME_WE)
+ get_filename_component(_abs_path "${_abs_current_FILE}" PATH)
+ set(_header "${_abs_path}/${_basename}.h")
+@@ -168,7 +168,7 @@
+ list(APPEND _moc_headers ${_pheader})
+ endif(EXISTS "${_pheader}")
+ list(APPEND _moc_files ${_abs_current_FILE})
+- endif(_suffix STREQUAL ".cpp" OR _suffix STREQUAL ".cc" OR _suffix STREQUAL ".cxx" OR _suffix STREQUAL ".C")
++ endif(_suffix STREQUAL ".cpp" OR _suffix STREQUAL ".cc" OR _suffix STREQUAL ".cxx" OR _suffix STREQUAL ".C" OR _suffix STREQUAL ".mm")
+ endif(NOT _generated AND NOT _skip)
+ endforeach (_current_FILE)
+
+--- trunk/kdesupport/automoc/kde4automoc.cpp 2009/03/03 15:40:57 934695
++++ trunk/kdesupport/automoc/kde4automoc.cpp 2009/03/03 15:42:18 934696
+@@ -326,7 +326,7 @@
+ foreach (const QString &absFilename, sourceFiles) {
+ //qDebug() << absFilename;
+ const QFileInfo sourceFileInfo(absFilename);
+- if (absFilename.endsWith(".cpp") || absFilename.endsWith(".cc") ||
++ if (absFilename.endsWith(".cpp") || absFilename.endsWith(".cc") || absFilename.endsWith(".mm") ||
+ absFilename.endsWith(".cxx") || absFilename.endsWith(".C")) {
+ //qDebug() << "check .cpp file";
+ QFile sourceFile(absFilename);
diff --git a/dev-util/automoc/metadata.xml b/dev-util/automoc/metadata.xml
new file mode 100644
index 000000000000..a23f444b67d6
--- /dev/null
+++ b/dev-util/automoc/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+</pkgmetadata>