summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHolger Hoffstätte <holger@applied-asynchrony.com>2023-01-13 11:04:17 +0100
committerSam James <sam@gentoo.org>2023-01-13 10:22:34 +0000
commite6371538947cff10c0d6dba0f36dd93af9b555f9 (patch)
tree35baaa0536dc6a2c187973cd075ef14f227a2c03 /dev-util/bpftool/files
parentsci-mathematics/gimps: Stabilize 30.8.17 amd64, #890640 (diff)
downloadgentoo-e6371538947cff10c0d6dba0f36dd93af9b555f9.tar.gz
gentoo-e6371538947cff10c0d6dba0f36dd93af9b555f9.tar.bz2
gentoo-e6371538947cff10c0d6dba0f36dd93af9b555f9.zip
dev-util/bftool: fix build with clang+ssp
Closes: https://bugs.gentoo.org/890638 Signed-off-by: Holger Hoffstätte <holger@applied-asynchrony.com> Closes: https://github.com/gentoo/gentoo/pull/29086 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/bpftool/files')
-rw-r--r--dev-util/bpftool/files/5.19.12-no-stack-protector.patch14
-rw-r--r--dev-util/bpftool/files/6.0.12-no-stack-protector.patch14
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/bpftool/files/5.19.12-no-stack-protector.patch b/dev-util/bpftool/files/5.19.12-no-stack-protector.patch
new file mode 100644
index 000000000000..c9ae115ac20d
--- /dev/null
+++ b/dev-util/bpftool/files/5.19.12-no-stack-protector.patch
@@ -0,0 +1,14 @@
+
+https://bugs.gentoo.org/890638
+
+--- a/tools/bpf/bpftool/Makefile 2022-12-11 23:15:18.000000000 +0100
++++ b/tools/bpf/bpftool/Makefile 2023-01-13 10:32:09.615048492 +0100
+@@ -187,7 +187,7 @@ $(OUTPUT)%.bpf.o: skeleton/%.bpf.c $(OUT
+ -I$(or $(OUTPUT),.) \
+ -I$(srctree)/tools/include/uapi/ \
+ -I$(LIBBPF_BOOTSTRAP_INCLUDE) \
+- -g -O2 -Wall -target bpf -c $< -o $@
++ -g -O2 -Wall -fno-stack-protector -target bpf -c $< -o $@
+ $(Q)$(LLVM_STRIP) -g $@
+
+ $(OUTPUT)%.skel.h: $(OUTPUT)%.bpf.o $(BPFTOOL_BOOTSTRAP)
diff --git a/dev-util/bpftool/files/6.0.12-no-stack-protector.patch b/dev-util/bpftool/files/6.0.12-no-stack-protector.patch
new file mode 100644
index 000000000000..c9ae115ac20d
--- /dev/null
+++ b/dev-util/bpftool/files/6.0.12-no-stack-protector.patch
@@ -0,0 +1,14 @@
+
+https://bugs.gentoo.org/890638
+
+--- a/tools/bpf/bpftool/Makefile 2022-12-11 23:15:18.000000000 +0100
++++ b/tools/bpf/bpftool/Makefile 2023-01-13 10:32:09.615048492 +0100
+@@ -187,7 +187,7 @@ $(OUTPUT)%.bpf.o: skeleton/%.bpf.c $(OUT
+ -I$(or $(OUTPUT),.) \
+ -I$(srctree)/tools/include/uapi/ \
+ -I$(LIBBPF_BOOTSTRAP_INCLUDE) \
+- -g -O2 -Wall -target bpf -c $< -o $@
++ -g -O2 -Wall -fno-stack-protector -target bpf -c $< -o $@
+ $(Q)$(LLVM_STRIP) -g $@
+
+ $(OUTPUT)%.skel.h: $(OUTPUT)%.bpf.o $(BPFTOOL_BOOTSTRAP)