summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2017-05-15 18:59:48 -0700
committerBrian Dolbec <dolsen@gentoo.org>2017-05-15 19:07:12 -0700
commitc36f613713157566d72591132c4c1a55e6a54e71 (patch)
treebc5f3a9a65756d9939315bd7010aa9d31d672be2 /dev-util/buildbot-pkg/buildbot-pkg-0.9.7.ebuild
parentdev-util/buildbot: Version bump, adds py3.5 capability (diff)
downloadgentoo-c36f613713157566d72591132c4c1a55e6a54e71.tar.gz
gentoo-c36f613713157566d72591132c4c1a55e6a54e71.tar.bz2
gentoo-c36f613713157566d72591132c4c1a55e6a54e71.zip
dev-util/buildbot-pkg: Version bump, adds py3.5 capability
Clean older versions. Package-Manager: Portage-2.3.5, Repoman-2.3.2_p30
Diffstat (limited to 'dev-util/buildbot-pkg/buildbot-pkg-0.9.7.ebuild')
-rw-r--r--dev-util/buildbot-pkg/buildbot-pkg-0.9.7.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-util/buildbot-pkg/buildbot-pkg-0.9.7.ebuild b/dev-util/buildbot-pkg/buildbot-pkg-0.9.7.ebuild
new file mode 100644
index 000000000000..6614ec70163c
--- /dev/null
+++ b/dev-util/buildbot-pkg/buildbot-pkg-0.9.7.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python2_7 python3_5 )
+
+EGIT_REPO_URI="git://github.com/buildbot/buildbot.git"
+
+[[ ${PV} == *9999 ]] && inherit git-r3
+inherit distutils-r1
+
+MY_V="${PV/_p/p}"
+MY_P="${PN}-${MY_V}"
+
+DESCRIPTION="BuildBot common www build tools for packaging releases"
+HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.python.org/pypi/buildbot-pkg"
+[[ ${PV} == *9999 ]] || SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+if [[ ${PV} == *9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+
+# No real integration tests for this pkg.
+# all tests are related to making releases and final checks for distribution
+
+RDEPEND="
+ ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
+"
+
+S=${WORKDIR}/${MY_P}
+
+python_install_all() {
+ distutils-r1_python_install_all
+}