summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-03-13 19:47:12 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-03-13 19:47:38 +0000
commitbfd879d66bc21ce8210c7e392b626a59bf981dcb (patch)
tree74af64e8a167ea3a25b4d378d36b8e71b0b7c28f /dev-util/ccache
parentdev-libs/clhpp: Version bump to 2.0.11 (diff)
downloadgentoo-bfd879d66bc21ce8210c7e392b626a59bf981dcb.tar.gz
gentoo-bfd879d66bc21ce8210c7e392b626a59bf981dcb.tar.bz2
gentoo-bfd879d66bc21ce8210c7e392b626a59bf981dcb.zip
dev-util/ccache: drop misleading install message
Even being relatively long readme.doc has a few limitations: - non-standard ccache usage requires a bit more fiddling than readme suggests - standard ccache usage is not covered fully (not make.conf tweaks, no caveats) Let's leave all the details to https://wiki.gentoo.org/wiki/Ccache page. Reported-by: Esteve Varela Colominas Closes: https://bugs.gentoo.org/712256 Package-Manager: Portage-2.3.93, Repoman-2.3.20 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-util/ccache')
-rw-r--r--dev-util/ccache/ccache-3.7.7-r2.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/dev-util/ccache/ccache-3.7.7-r2.ebuild b/dev-util/ccache/ccache-3.7.7-r2.ebuild
new file mode 100644
index 000000000000..e884b459f8d0
--- /dev/null
+++ b/dev-util/ccache/ccache-3.7.7-r2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="fast compiler cache"
+HOMEPAGE="https://ccache.dev/"
+SRC_URI="https://github.com/ccache/ccache/releases/download/v${PV}/ccache-${PV}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+
+DEPEND="app-arch/xz-utils
+ sys-libs/zlib"
+RDEPEND="${DEPEND}
+ dev-util/shadowman
+ sys-apps/gentoo-functions"
+# clang-specific tests use dev-libs/elfutils to compare objects for equality.
+# Let's pull in the dependency unconditionally.
+DEPEND+="
+ test? ( dev-libs/elfutils )"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.5-nvcc-test.patch
+)
+
+src_prepare() {
+ default
+
+ sed \
+ -e "/^EPREFIX=/s:'':'${EPREFIX}':" \
+ "${FILESDIR}"/ccache-config-3 > ccache-config || die
+}
+
+src_configure() {
+ econf --without-bundled-zlib
+}
+
+src_compile() {
+ emake V=1
+}
+
+src_test() {
+ emake check V=1
+}
+
+src_install() {
+ DOCS=( doc/{AUTHORS,MANUAL,NEWS}.adoc CONTRIBUTING.md README.md )
+ default
+
+ dobin ccache-config
+ insinto /usr/share/shadowman/tools
+ newins - ccache <<<"${EPREFIX}/usr/lib/ccache/bin"
+}
+
+pkg_prerm() {
+ if [[ -z ${REPLACED_BY_VERSION} && ${ROOT:-/} == / ]] ; then
+ eselect compiler-shadow remove ccache
+ fi
+}
+
+pkg_postinst() {
+ if [[ ${ROOT:-/} == / ]]; then
+ eselect compiler-shadow update ccache
+ fi
+}