summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2022-12-08 16:09:12 +0300
committerSergey Popov <pinkbyte@gentoo.org>2022-12-08 16:11:34 +0300
commit0c609656941d50f5e8b55059f77956160fad9776 (patch)
treebadefac30125f879a97410769b96efc0941797b6 /dev-util/clippy
parentapp-portage/mgorny-dev-scripts: Bump to v31 (diff)
downloadgentoo-0c609656941d50f5e8b55059f77956160fad9776.tar.gz
gentoo-0c609656941d50f5e8b55059f77956160fad9776.tar.bz2
gentoo-0c609656941d50f5e8b55059f77956160fad9776.zip
dev-util/clippy: version bump
Signed-off-by: Sergey Popov <pinkbyte@gentoo.org> Bug: https://bugs.gentoo.org/877827
Diffstat (limited to 'dev-util/clippy')
-rw-r--r--dev-util/clippy/Manifest1
-rw-r--r--dev-util/clippy/clippy-8.4.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-util/clippy/Manifest b/dev-util/clippy/Manifest
index 232966752b97..638729225ca7 100644
--- a/dev-util/clippy/Manifest
+++ b/dev-util/clippy/Manifest
@@ -1 +1,2 @@
DIST clippy-8.2.2.tar.gz 9439460 BLAKE2B 7ea4b44e3d167677e087ac8767c470b91c485e52f9e45513fb6da8498ff3c56e84dd90257eff3b0067c061e7596578968017cbec7de7ea951b6f80134332e1bf SHA512 52d8e82979823f61ec6f117db1eb41b23fd8ad3197ae3f9d2cfa3ad9d96636a3d2f0b36720b2041a9261c8b639ddd48e46a2351ce41cb596f7dc432cddf29256
+DIST clippy-8.4.1.tar.gz 9886182 BLAKE2B be270f34e9ffdbf87a10c7bbd73e9f244128821f1c014060880015e4e7e06165dbc1dc3253894bda5dc1a0607a5bdbad21a70532e9019f1e06d0abd24beffff1 SHA512 69f936580d2e7838e1f15fdfa71a4fa00e7acaa93df4cdbd6129560fbcd45f3754cf5d03b4c9331bf4850477560d63d5509d185098583d19fa93d9e960e1483a
diff --git a/dev-util/clippy/clippy-8.4.1.ebuild b/dev-util/clippy/clippy-8.4.1.ebuild
new file mode 100644
index 000000000000..9145b460dbf0
--- /dev/null
+++ b/dev-util/clippy/clippy-8.4.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="frr-${PV}"
+PYTHON_COMPAT=( python3_{8..11} )
+inherit autotools python-single-r1
+
+DESCRIPTION="Standalone clippy tool built from FRR sources"
+HOMEPAGE="https://frrouting.org/"
+SRC_URI="https://github.com/FRRouting/frr/archive/${MY_P}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/frr-${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# standalone clippy does not have any tests
+# restrict to prevent bug 811753
+RESTRICT="test"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ virtual/libelf:=
+"
+RDEPEND="${DEPEND}"
+BDEPEND="sys-devel/flex"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --enable-clippy-only
+}
+
+src_install() {
+ # 830087
+ find "lib" -type f -name "clippy" -print0 |
+ xargs -0 file | grep executable | grep ELF | cut -f 1 -d : |
+ xargs -I '{}' dobin '{}' ||
+ die "Failed to install 'lib/clippy'"
+}