summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNikos Chantziaras <realnc@gmail.com>2019-02-27 15:22:58 +0200
committerMatthias Maier <tamiko@gentoo.org>2019-03-02 17:46:26 -0600
commit2d77eab1ffd0076f700684a8ce3ff38a6491e59f (patch)
treeda20316dfcb9e039a31dde2dfa5979f7c28d6803 /dev-util/cloc/cloc-1.80.ebuild
parentapp-emulation/qemu-9999: Drop --with-sdlabi configure argument (diff)
downloadgentoo-2d77eab1ffd0076f700684a8ce3ff38a6491e59f.tar.gz
gentoo-2d77eab1ffd0076f700684a8ce3ff38a6491e59f.tar.bz2
gentoo-2d77eab1ffd0076f700684a8ce3ff38a6491e59f.zip
dev-util/cloc: bump version to 1.80 and EAPI to 7
Closes: https://bugs.gentoo.org/678922 Closes: https://github.com/gentoo/gentoo/pull/11170 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Nikos Chantziaras <realnc@gmail.com> Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'dev-util/cloc/cloc-1.80.ebuild')
-rw-r--r--dev-util/cloc/cloc-1.80.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-util/cloc/cloc-1.80.ebuild b/dev-util/cloc/cloc-1.80.ebuild
new file mode 100644
index 000000000000..19fd2288e575
--- /dev/null
+++ b/dev-util/cloc/cloc-1.80.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Count Lines of Code"
+HOMEPAGE="https://github.com/AlDanial/cloc"
+SRC_URI="https://github.com/AlDanial/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}
+ dev-perl/Algorithm-Diff
+ dev-perl/Parallel-ForkManager
+ dev-perl/Regexp-Common
+ virtual/perl-Digest-MD5
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ virtual/perl-Getopt-Long"
+
+src_compile() {
+ pod2man "Unix/${PN}.1.pod" > "${PN}.1" || die
+}
+
+src_install() {
+ doman "${PN}.1"
+ dobin "Unix/${PN}"
+}