summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Czapiga <jacz@semihalf.com>2022-01-20 10:40:10 +0100
committerSam James <sam@gentoo.org>2022-01-28 07:59:35 +0000
commit19edcd377f662c55aae15bc8fc15ae0fe7e07c3a (patch)
tree7d5afbf94d7c80472a3975639dc94aaf3f1b2f71 /dev-util/cscope
parent*/*: limit dependencies for older versions of skarnet software (diff)
downloadgentoo-19edcd377f662c55aae15bc8fc15ae0fe7e07c3a.tar.gz
gentoo-19edcd377f662c55aae15bc8fc15ae0fe7e07c3a.tar.bz2
gentoo-19edcd377f662c55aae15bc8fc15ae0fe7e07c3a.zip
dev-util/cscope: Fix direct call of pkg-config in configure script
Signed-off-by: Jakub Czapiga <jacz@semihalf.com> Closes: https://github.com/gentoo/gentoo/pull/23883 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/cscope')
-rw-r--r--dev-util/cscope/cscope-15.8a-r2.ebuild1
-rw-r--r--dev-util/cscope/cscope-15.9.ebuild1
-rw-r--r--dev-util/cscope/files/cscope-15.8a-pkgconfig.patch28
-rw-r--r--dev-util/cscope/files/cscope-15.9-pkgconfig.patch28
4 files changed, 58 insertions, 0 deletions
diff --git a/dev-util/cscope/cscope-15.8a-r2.ebuild b/dev-util/cscope/cscope-15.8a-r2.ebuild
index b2707fe35459..95facd63cb4f 100644
--- a/dev-util/cscope/cscope-15.8a-r2.ebuild
+++ b/dev-util/cscope/cscope-15.8a-r2.ebuild
@@ -26,6 +26,7 @@ SITEFILE="50${PN}-gentoo.el"
src_prepare() {
eapply "${FILESDIR}/${PN}-15.7a-ocs-sysdir.patch" #269305
eapply "${FILESDIR}/${PN}-15.6-darwin.patch"
+ eapply "${FILESDIR}/${PN}-15.8a-pkgconfig.patch"
eapply_user
mv configure.{in,ac} || die
eautoreconf # prevent maintainer mode later on
diff --git a/dev-util/cscope/cscope-15.9.ebuild b/dev-util/cscope/cscope-15.9.ebuild
index 1cad13f52943..cdee9e4703fd 100644
--- a/dev-util/cscope/cscope-15.9.ebuild
+++ b/dev-util/cscope/cscope-15.9.ebuild
@@ -25,6 +25,7 @@ SITEFILE="50${PN}-gentoo.el"
src_prepare() {
eapply "${FILESDIR}/${PN}-15.7a-ocs-sysdir.patch" #269305
+ eapply "${FILESDIR}/${PN}-15.9-pkgconfig.patch"
eapply_user
mv configure.{in,ac} || die
eautoreconf # prevent maintainer mode later on
diff --git a/dev-util/cscope/files/cscope-15.8a-pkgconfig.patch b/dev-util/cscope/files/cscope-15.8a-pkgconfig.patch
new file mode 100644
index 000000000000..665b7169761e
--- /dev/null
+++ b/dev-util/cscope/files/cscope-15.8a-pkgconfig.patch
@@ -0,0 +1,28 @@
+--- a/configure.in
++++ b/configure.in
+@@ -22,6 +22,7 @@ if test "x$LEX" = "xlex" ; then AC_DEFINE(USING_LEX, 1,
+ [Define this if the scanner is run through lex, not flex])
+ fi
+ AC_PROG_YACC
++PKG_PROG_PKG_CONFIG
+
+ dnl === BEGIN CURSES CHECK
+ dnl Curses detection: Munged from Midnight Commander's configure.in
+@@ -363,7 +364,7 @@ dnl Check for a GNOME installation
+ AC_DEFUN([AC_CHECK_GNOME],[
+ has_gnome=false
+ AC_CHECK_PROG(gnome1, gnome-config, true)
+- AC_CHECK_PROG(gnome2, pkg-config, true)
++ AC_CHECK_PROG(gnome2, $PKG_CONFIG, true)
+
+ if test x$gnome1 = xtrue; then
+ has_gnome=true
+@@ -373,7 +374,7 @@ AC_DEFUN([AC_CHECK_GNOME],[
+ has_gnome=true
+ fi
+
+- AM_CONDITIONAL(USING_GNOME2, pkg-config --exists gtk+-2.0)
++ AM_CONDITIONAL(USING_GNOME2, $PKG_CONFIG --exists gtk+-2.0)
+ AM_CONDITIONAL(HAS_GNOME, test "$has_gnome" = true)
+ AM_CONDITIONAL(GNOME_LINUX, test "$host_os" = Linux)
+ ])
diff --git a/dev-util/cscope/files/cscope-15.9-pkgconfig.patch b/dev-util/cscope/files/cscope-15.9-pkgconfig.patch
new file mode 100644
index 000000000000..c031633a6559
--- /dev/null
+++ b/dev-util/cscope/files/cscope-15.9-pkgconfig.patch
@@ -0,0 +1,28 @@
+--- a/configure.in
++++ b/configure.in
+@@ -18,6 +18,7 @@ if test "x$LEX" = "xlex" ; then AC_DEFINE(USING_LEX, 1,
+ [Define this if the scanner is run through lex, not flex])
+ fi
+ AC_PROG_YACC
++PKG_PROG_PKG_CONFIG
+
+ AC_SYS_LARGEFILE
+
+@@ -361,7 +362,7 @@ dnl Check for a GNOME installation
+ AC_DEFUN([AC_CHECK_GNOME],[
+ has_gnome=false
+ AC_CHECK_PROG(gnome1, gnome-config, true)
+- AC_CHECK_PROG(gnome2, pkg-config, true)
++ AC_CHECK_PROG(gnome2, $PKG_CONFIG, true)
+
+ if test x$gnome1 = xtrue; then
+ has_gnome=true
+@@ -371,7 +372,7 @@ AC_DEFUN([AC_CHECK_GNOME],[
+ has_gnome=true
+ fi
+
+- AM_CONDITIONAL(USING_GNOME2, pkg-config --exists gtk+-2.0)
++ AM_CONDITIONAL(USING_GNOME2, $PKG_CONFIG --exists gtk+-2.0)
+ AM_CONDITIONAL(HAS_GNOME, test "$has_gnome" = true)
+ AM_CONDITIONAL(GNOME_LINUX, test "$host_os" = Linux)
+ ])