summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-06-22 22:57:00 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-06-22 22:57:00 +0200
commitd84d80228793e521c259cd298beafb80de5dfe51 (patch)
tree6758c8b5c80e8a22213588666f3a1ff075161b92 /dev-util/dejagnu/dejagnu-1.6.ebuild
parentnet-nntp/nzbget: remove old (diff)
downloadgentoo-d84d80228793e521c259cd298beafb80de5dfe51.tar.gz
gentoo-d84d80228793e521c259cd298beafb80de5dfe51.tar.bz2
gentoo-d84d80228793e521c259cd298beafb80de5dfe51.zip
dev-util/dejagnu: Versopm ni,ü
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-util/dejagnu/dejagnu-1.6.ebuild')
-rw-r--r--dev-util/dejagnu/dejagnu-1.6.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/dejagnu/dejagnu-1.6.ebuild b/dev-util/dejagnu/dejagnu-1.6.ebuild
new file mode 100644
index 000000000000..6ea9754aa795
--- /dev/null
+++ b/dev-util/dejagnu/dejagnu-1.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Framework for testing other programs"
+HOMEPAGE="https://www.gnu.org/software/dejagnu/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
+IUSE="doc"
+
+DEPEND="dev-lang/tcl
+ dev-tcltk/expect"
+
+src_test() {
+ # if you dont have dejagnu emerged yet, you cant
+ # run the tests ... crazy aint it :)
+ type -p runtest || return 0
+ emake check
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ use doc && dodoc -r doc/html
+}