summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/desktop-file-utils
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/desktop-file-utils')
-rw-r--r--dev-util/desktop-file-utils/Manifest2
-rw-r--r--dev-util/desktop-file-utils/desktop-file-utils-0.21.ebuild54
-rw-r--r--dev-util/desktop-file-utils/desktop-file-utils-0.22.ebuild54
-rw-r--r--dev-util/desktop-file-utils/files/50desktop-file-utils-gentoo.el5
-rw-r--r--dev-util/desktop-file-utils/metadata.xml8
5 files changed, 123 insertions, 0 deletions
diff --git a/dev-util/desktop-file-utils/Manifest b/dev-util/desktop-file-utils/Manifest
new file mode 100644
index 000000000000..ccbf3c8f2944
--- /dev/null
+++ b/dev-util/desktop-file-utils/Manifest
@@ -0,0 +1,2 @@
+DIST desktop-file-utils-0.21.tar.xz 128972 SHA256 b6c9b860538ef1cffbcdfbc9cb578f85a080ad8c1207c8b3a39e9fd183f9782b SHA512 c7372d820e996eef72e85c7190c7f7cce61a3e08ebc348822013d1b28971db294242ce108d8f5e8e6c7539f9044619511d2bba0459a319bddbe5e5cf5d8665aa WHIRLPOOL 04e4957c52f5093db72a92735ac2438163303eac3edb3f0ec0361aa08c8cbca3a06cc648074f13dd5764afc86a1725fc6e9d85fac2e10bc2352b2ce56e970379
+DIST desktop-file-utils-0.22.tar.xz 131028 SHA256 843532672692f98e9b2d6ae6cc8658da562dfde1606c7f33d9d227a344de56c5 SHA512 26c1f0da44e4d3fc286640084ad1fad0595fc94edb5d2edd2a4d8cbed0aea4e409aa1a610cbba372f8e540188b62aed764fc7fdecddefbcfeeaedd1d19e3d20a WHIRLPOOL 70d57623cb16d5ecdb4a1cb24fd4545f6d4dfe7aba51446570684cf09eb1d498c0ce575ad8f3255289dd15987d632b76c51b99a335cb9f3a3099d2901bdaf2ea
diff --git a/dev-util/desktop-file-utils/desktop-file-utils-0.21.ebuild b/dev-util/desktop-file-utils/desktop-file-utils-0.21.ebuild
new file mode 100644
index 000000000000..2c34679c3e42
--- /dev/null
+++ b/dev-util/desktop-file-utils/desktop-file-utils-0.21.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit elisp-common eutils
+
+DESCRIPTION="Command line utilities to work with desktop menu entries"
+HOMEPAGE="http://freedesktop.org/wiki/Software/desktop-file-utils"
+SRC_URI="http://www.freedesktop.org/software/${PN}/releases/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="emacs"
+
+RDEPEND=">=dev-libs/glib-2.12:2
+ emacs? ( virtual/emacs )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig"
+
+SITEFILE=50${PN}-gentoo.el
+
+DOCS=( AUTHORS ChangeLog HACKING NEWS README )
+
+src_prepare() {
+ sed -i -e '/SUBDIRS =/s:misc::' Makefile.in || die
+}
+
+src_configure() {
+ econf "$(use_with emacs lispdir "${SITELISP}"/${PN})"
+}
+
+src_compile() {
+ default
+ use emacs && elisp-compile misc/desktop-entry-mode.el
+}
+
+src_install() {
+ default
+ if use emacs; then
+ elisp-install ${PN} misc/*.el misc/*.elc || die
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE} || die
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-util/desktop-file-utils/desktop-file-utils-0.22.ebuild b/dev-util/desktop-file-utils/desktop-file-utils-0.22.ebuild
new file mode 100644
index 000000000000..024caf3a08cd
--- /dev/null
+++ b/dev-util/desktop-file-utils/desktop-file-utils-0.22.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit elisp-common eutils
+
+DESCRIPTION="Command line utilities to work with desktop menu entries"
+HOMEPAGE="http://freedesktop.org/wiki/Software/desktop-file-utils"
+SRC_URI="http://www.freedesktop.org/software/${PN}/releases/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="emacs"
+
+RDEPEND=">=dev-libs/glib-2.12:2
+ emacs? ( virtual/emacs )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig"
+
+SITEFILE=50${PN}-gentoo.el
+
+DOCS=( AUTHORS ChangeLog HACKING NEWS README )
+
+src_prepare() {
+ sed -i -e '/SUBDIRS =/s:misc::' Makefile.in || die
+}
+
+src_configure() {
+ econf "$(use_with emacs lispdir "${SITELISP}"/${PN})"
+}
+
+src_compile() {
+ default
+ use emacs && elisp-compile misc/desktop-entry-mode.el
+}
+
+src_install() {
+ default
+ if use emacs; then
+ elisp-install ${PN} misc/*.el misc/*.elc || die
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE} || die
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-util/desktop-file-utils/files/50desktop-file-utils-gentoo.el b/dev-util/desktop-file-utils/files/50desktop-file-utils-gentoo.el
new file mode 100644
index 000000000000..546947a0b374
--- /dev/null
+++ b/dev-util/desktop-file-utils/files/50desktop-file-utils-gentoo.el
@@ -0,0 +1,5 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'desktop-entry-mode "desktop-entry-mode" "Desktop Entry mode" t)
+(add-to-list 'auto-mode-alist
+ '("\\.desktop\\(\\.in\\)?$" . desktop-entry-mode))
+(add-hook 'desktop-entry-mode-hook 'turn-on-font-lock)
diff --git a/dev-util/desktop-file-utils/metadata.xml b/dev-util/desktop-file-utils/metadata.xml
new file mode 100644
index 000000000000..8c868061b739
--- /dev/null
+++ b/dev-util/desktop-file-utils/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>freedesktop</herd>
+<maintainer>
+<email>freedesktop-bugs@gentoo.org</email>
+</maintainer>
+</pkgmetadata>