summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2021-02-08 21:55:48 +0100
committerAlfredo Tupone <tupone@gentoo.org>2021-02-08 21:55:48 +0100
commita71b49cf150f9a10f06717c16906284eaf9af446 (patch)
tree4580be630311deef2de2e287a5b27f14fc810624 /dev-util/flawfinder/flawfinder-2.0.15.ebuild
parentmail-client/roundcube: 1.4.11 version bump (diff)
downloadgentoo-a71b49cf150f9a10f06717c16906284eaf9af446.tar.gz
gentoo-a71b49cf150f9a10f06717c16906284eaf9af446.tar.bz2
gentoo-a71b49cf150f9a10f06717c16906284eaf9af446.zip
dev-util/flawfinder: take it and bump to 2.0.15
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-util/flawfinder/flawfinder-2.0.15.ebuild')
-rw-r--r--dev-util/flawfinder/flawfinder-2.0.15.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/flawfinder/flawfinder-2.0.15.ebuild b/dev-util/flawfinder/flawfinder-2.0.15.ebuild
new file mode 100644
index 000000000000..445563b0e667
--- /dev/null
+++ b/dev-util/flawfinder/flawfinder-2.0.15.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Examines C/C++ source code for security flaws"
+HOMEPAGE="https://www.dwheeler.com/flawfinder/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i "s/${PN}.1.gz/${PN}.1/g" setup.py || die 'sed failed.'
+ default
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ local DOCS=( announcement ChangeLog README.md ${PN}.pdf )
+ distutils-r1_python_install_all
+}