summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2023-08-25 13:47:59 +0200
committerAlexis Ballier <aballier@gentoo.org>2023-08-25 14:54:03 +0200
commit9a267c4d595e9b84222342389ee00bf75a675b3c (patch)
tree967fb6496084fc9af978c7b38b0b822d507aa47a /dev-util/ignition-cmake
parentdev-util/ignition-cmake: bump to 2.17.0 (diff)
downloadgentoo-9a267c4d595e9b84222342389ee00bf75a675b3c.tar.gz
gentoo-9a267c4d595e9b84222342389ee00bf75a675b3c.tar.bz2
gentoo-9a267c4d595e9b84222342389ee00bf75a675b3c.zip
dev-util/ignition-cmake: Fix find protobuf
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-util/ignition-cmake')
-rw-r--r--dev-util/ignition-cmake/files/protobuf.patch54
-rw-r--r--dev-util/ignition-cmake/ignition-cmake-2.17.0.ebuild3
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-util/ignition-cmake/files/protobuf.patch b/dev-util/ignition-cmake/files/protobuf.patch
new file mode 100644
index 000000000000..1bb2fe6480bb
--- /dev/null
+++ b/dev-util/ignition-cmake/files/protobuf.patch
@@ -0,0 +1,54 @@
+Index: ignition-cmake-2.17.0/cmake/FindIgnProtobuf.cmake
+===================================================================
+--- ignition-cmake-2.17.0.orig/cmake/FindIgnProtobuf.cmake
++++ ignition-cmake-2.17.0/cmake/FindIgnProtobuf.cmake
+@@ -26,12 +26,12 @@
+ include(IgnPkgConfig)
+ ign_pkg_config_entry(IgnProtobuf "protobuf >= ${IgnProtobuf_FIND_VERSION}")
+
+-find_package(Protobuf ${IgnProtobuf_FIND_VERSION} QUIET CONFIG)
++find_package(protobuf ${IgnProtobuf_FIND_VERSION} QUIET CONFIG)
+
+-if(NOT ${Protobuf_FOUND})
++if(NOT ${protobuf_FOUND})
+ # If a config-file was not found, then fall back on the system-installed
+ # find-module that comes with CMake.
+- find_package(Protobuf ${IgnProtobuf_FIND_VERSION})
++ find_package(protobuf ${IgnProtobuf_FIND_VERSION})
+ endif()
+
+ set(IgnProtobuf_missing_components "")
+@@ -49,21 +49,21 @@ foreach(component ${IgnProtobuf_FIND_COM
+
+ if((${component} STREQUAL "libprotobuf") OR (${component} STREQUAL "all"))
+ if((NOT PROTOBUF_LIBRARY) AND (NOT TARGET protobuf::libprotobuf))
+- set(Protobuf_FOUND false)
++ set(protobuf_FOUND false)
+ ign_string_append(IgnProtobuf_missing_components "libprotobuf" DELIM " ")
+ endif()
+ endif()
+
+ if((${component} STREQUAL "libprotoc") OR (${component} STREQUAL "all"))
+ if((NOT PROTOBUF_PROTOC_LIBRARY) AND (NOT TARGET protobuf::libprotoc))
+- set(Protobuf_FOUND false)
++ set(protobuf_FOUND false)
+ ign_string_append(IgnProtobuf_missing_components "libprotoc" DELIM " ")
+ endif()
+ endif()
+
+ if((${component} STREQUAL "protoc") OR (${component} STREQUAL "all"))
+ if((NOT PROTOBUF_PROTOC_EXECUTABLE) AND (NOT TARGET protobuf::protoc))
+- set(Protobuf_FOUND false)
++ set(protobuf_FOUND false)
+ ign_string_append(IgnProtobuf_missing_components "protoc" DELIM " ")
+ endif()
+ endif()
+@@ -74,7 +74,7 @@ if(IgnProtobuf_missing_components AND NO
+ message(STATUS "Missing required protobuf components: ${IgnProtobuf_missing_components}")
+ endif()
+
+-if(${Protobuf_FOUND})
++if(${protobuf_FOUND})
+ # If we have found Protobuf, then set the IgnProtobuf_FOUND flag to true so
+ # that ign_find_package(~) knows that we were successful.
+ set(IgnProtobuf_FOUND true)
diff --git a/dev-util/ignition-cmake/ignition-cmake-2.17.0.ebuild b/dev-util/ignition-cmake/ignition-cmake-2.17.0.ebuild
index 52d3b6de808d..b19b57da6d01 100644
--- a/dev-util/ignition-cmake/ignition-cmake-2.17.0.ebuild
+++ b/dev-util/ignition-cmake/ignition-cmake-2.17.0.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake
@@ -14,6 +14,7 @@ SLOT="2"
KEYWORDS="~amd64"
IUSE="test"
RESTRICT="!test? ( test )"
+PATCHES=( "${FILESDIR}/protobuf.patch" )
src_configure() {
local mycmakeargs=(