summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-05-25 00:30:41 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-05-25 00:30:48 +0100
commite24a14097a87b18124fd1a9bca987ede81e3119f (patch)
tree367e933e38c9296d071b64f39b267ea3579087e7 /dev-util/include-what-you-use
parentdev-python/denonavr: bump to 0.9.1 (diff)
downloadgentoo-e24a14097a87b18124fd1a9bca987ede81e3119f.tar.gz
gentoo-e24a14097a87b18124fd1a9bca987ede81e3119f.tar.bz2
gentoo-e24a14097a87b18124fd1a9bca987ede81e3119f.zip
dev-util/include-what-you-use: bump up to 10.0
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-util/include-what-you-use')
-rw-r--r--dev-util/include-what-you-use/Manifest1
-rw-r--r--dev-util/include-what-you-use/include-what-you-use-10.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-util/include-what-you-use/Manifest b/dev-util/include-what-you-use/Manifest
index 380480c41d90..8c52fd8cf1cb 100644
--- a/dev-util/include-what-you-use/Manifest
+++ b/dev-util/include-what-you-use/Manifest
@@ -1 +1,2 @@
+DIST include-what-you-use-10.0.tar.gz 598644 BLAKE2B 36c81bd493edfdfdc4df31c2dcb49d5acd3f6016f706e0c9d2f031d668ca16d71797d40b04fc9dc25a21738f7075320406fd666db74a0baa3832c149fe674e0e SHA512 e54a7c7e3a6d3e0de7c263d1f26b373d95b8fab5f1f7e76f52d80341bda2bad0fb12238a325dc1e2f6d3ab5e6d8e0b4ed60b5a19dc82e06d480bcb461f9aefba
DIST include-what-you-use-9.0.src.tar.gz 589377 BLAKE2B b695354787070948d81e3e80b07bbe47a84b5609262df2220b6a62e6d648865b17e060951819f45956c6ca858977614d6e0401640509599b391a1165521b20de SHA512 f2d6ba05121a9968da9e42e8ac66f83ca0f35bfbe7cb1d616e2c6479cf2833c4668cb86e46a04ffcd5e77f10a575da9eeee5272c7609b5afad555d79cb640fb4
diff --git a/dev-util/include-what-you-use/include-what-you-use-10.0.ebuild b/dev-util/include-what-you-use/include-what-you-use-10.0.ebuild
new file mode 100644
index 000000000000..da2675ad0e22
--- /dev/null
+++ b/dev-util/include-what-you-use/include-what-you-use-10.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit cmake-utils flag-o-matic llvm python-single-r1
+
+# Sometimes the tag is clang_9, timetimes it's IWYU-0.13
+UPSTREAM_PV=0.14
+
+DESCRIPTION="Find unused include directives in C/C++ programs"
+HOMEPAGE="https://include-what-you-use.org/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${UPSTREAM_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+LLVM_MAX_SLOT=10
+
+RDEPEND="sys-devel/llvm:${LLVM_MAX_SLOT}
+ sys-devel/clang:${LLVM_MAX_SLOT}
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+S=${WORKDIR}/${PN}-${UPSTREAM_PV}
+
+pkg_setup() {
+ llvm_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ cmake-utils_src_prepare
+ python_fix_shebang .
+}
+
+src_configure() {
+ local mycmakeargs=(
+ # Note [llvm install path]
+ # Unfortunately all binaries using clang driver
+ # have to reside at the same path depth as
+ # 'clang' binary itself. See bug #625972
+ # Thus as a hack we install it to the same directory
+ # as llvm/clang itself.
+ -DCMAKE_INSTALL_PREFIX="$(get_llvm_prefix "${LLVM_MAX_SLOT}")"
+ )
+ cmake-utils_src_configure
+}
+
+src_test() {
+ "${EPYTHON}" run_iwyu_tests.py
+}