summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor V. Kovalenko <igor.v.kovalenko@gmail.com>2022-12-24 18:08:32 +0300
committerSam James <sam@gentoo.org>2022-12-27 10:21:54 +0000
commit29f35ebfcf68e1315817497f28826edfcdf834d9 (patch)
tree541dc95641209f7e57b6eefa9dbe203611a8219d /dev-util/lttng-tools
parentdev-util/lttng-ust: add 2.13.5 (diff)
downloadgentoo-29f35ebfcf68e1315817497f28826edfcdf834d9.tar.gz
gentoo-29f35ebfcf68e1315817497f28826edfcdf834d9.tar.bz2
gentoo-29f35ebfcf68e1315817497f28826edfcdf834d9.zip
dev-util/lttng-tools: add 2.13.8
Signed-off-by: Igor V. Kovalenko <igor.v.kovalenko@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/28786 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/lttng-tools')
-rw-r--r--dev-util/lttng-tools/Manifest1
-rw-r--r--dev-util/lttng-tools/lttng-tools-2.13.8.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/lttng-tools/Manifest b/dev-util/lttng-tools/Manifest
index 110ca1ba0126..8faf415458e0 100644
--- a/dev-util/lttng-tools/Manifest
+++ b/dev-util/lttng-tools/Manifest
@@ -2,3 +2,4 @@ DIST lttng-tools-2.12.11.tar.bz2 1587429 BLAKE2B 9c8bc7803dad413f1c16d0e0bb25ada
DIST lttng-tools-2.12.3.tar.bz2 1550901 BLAKE2B 0f4a5ac780e26f6ef16f4c71af7052083b4889664962712bf248cc6a7c05e8448a40b12dd9fe615e41519924e285b629e7ed535cf551581b26890a2b8fd58cad SHA512 f997e94a5d6126845b914d8b80a5e1512d49799e84c6cc82903187b988da2b0f157d65d7fe8f14d01fd3b5352aa317c5305bcd6b56f81d03a85a561a18be2a0c
DIST lttng-tools-2.12.5.tar.bz2 1576936 BLAKE2B d5e0590ef97b899988a9c2be916fc742e025eb986fe6537528eb98ff342ad301721fa3c4142937400b1deed59e725581f693f4adae1cb85da7ee1f7287283b4f SHA512 5b7295443681f3faa0409b6385f2aea07bd07b0c01f03c9a0f21d5055d73987b9bc34116e6b0e742f7fb17b5e93fc435d578e658813f1a11261b317ceabb136f
DIST lttng-tools-2.13.7.tar.bz2 1885363 BLAKE2B 20a48a75b53045a54e0293ff17e25cc940040f3be95917c3cd3cc5245d6afd0d58a4eb2915665eb35773cdcbd84f317398028c4b8481bc2df7f78175eaa10c27 SHA512 e5730cb600d39f4e5608fc14f5a211628c3eb1de043cf36fdd021c5d3d0e5e9f1d95bbde554c7ad33b5c1c817ae6a8a893f5cf52a678adf82a2f2c95565a127d
+DIST lttng-tools-2.13.8.tar.bz2 1905545 BLAKE2B 59aab1ae627f6a0230fc716adb9b4722b0f0df599cd9b6b5bae4e44a22dae5d309c698fd5b84a88d1096ea27fd50fac6d53e89bb699294fd781cdbdd9d181bbd SHA512 6daafb1fd458cfbaa7e19b3a8aaafa958116bb836f389febf7ac4035e5d7884d308a9fdefb4e9063329cb7d837853a79ddae0e263d3b58db1f87519bba2dcb3b
diff --git a/dev-util/lttng-tools/lttng-tools-2.13.8.ebuild b/dev-util/lttng-tools/lttng-tools-2.13.8.ebuild
new file mode 100644
index 000000000000..da53b8a61108
--- /dev/null
+++ b/dev-util/lttng-tools/lttng-tools-2.13.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="${P/_rc/-rc}"
+MY_SLOT="$(ver_cut 1-2)"
+
+DESCRIPTION="Linux Trace Toolkit - next generation"
+HOMEPAGE="https://lttng.org"
+SRC_URI="https://lttng.org/files/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0/${MY_SLOT}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ust"
+
+DEPEND="dev-libs/userspace-rcu:=
+ dev-libs/popt
+ dev-libs/libxml2
+ ust? ( >=dev-util/lttng-ust-2.13.0:= )
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ econf $(usex ust "" --without-lttng-ust) --disable-static
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}