summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-12 03:00:54 +0100
committerSam James <sam@gentoo.org>2023-05-12 03:55:36 +0100
commit173b5091da7b6aa2f775943f24912e1a8616d9a4 (patch)
tree66d477203eede46589e5d9522426ca5a93b536f4 /dev-util/lv2lint/lv2lint-0.16.2.ebuild
parentdev-python/docker-py: Bump to 6.1.2 (diff)
downloadgentoo-173b5091da7b6aa2f775943f24912e1a8616d9a4.tar.gz
gentoo-173b5091da7b6aa2f775943f24912e1a8616d9a4.tar.bz2
gentoo-173b5091da7b6aa2f775943f24912e1a8616d9a4.zip
dev-util/lv2lint: new package, add 0.16.2
Test dep of media-plugins/mda-lv2. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/lv2lint/lv2lint-0.16.2.ebuild')
-rw-r--r--dev-util/lv2lint/lv2lint-0.16.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/lv2lint/lv2lint-0.16.2.ebuild b/dev-util/lv2lint/lv2lint-0.16.2.ebuild
new file mode 100644
index 000000000000..feeeadef363b
--- /dev/null
+++ b/dev-util/lv2lint/lv2lint-0.16.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Check whether a given LV2 plugin is up to the specification"
+HOMEPAGE="https://git.open-music-kontrollers.ch/~hp/lv2lint"
+SRC_URI="https://git.open-music-kontrollers.ch/~hp/lv2lint/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Artistic-2 CC0-1.0 ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ media-libs/lilv
+ media-libs/lv2
+ virtual/libelf
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # TODO: on next release (>0.16.2), wire up -Dbuild-tests
+ local emesonargs=(
+ -Db_lto=false
+
+ # See README, these are for runtime tests of *other* things (plugins)
+ -Donline-tests=disabled
+ -Delf-tests=enabled
+ -Dx11-tests=disabled
+ )
+
+ meson_src_configure
+}