summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Joldasov <bratishkaerik@getgoogleoff.me>2022-11-25 14:20:44 +0600
committerViorel Munteanu <ceamac@gentoo.org>2022-12-13 20:28:29 +0200
commitf108551b0c1f39744cef0deab1b5184b7cd2d2de (patch)
treebfcb58f338626da938378b047e8546ffa0cc06f4 /dev-util/makeheaders/makeheaders-0_p20220411.ebuild
parentmedia-plugins/gst-plugins-srtp: Stabilize 1.20.4 arm64, #884731 (diff)
downloadgentoo-f108551b0c1f39744cef0deab1b5184b7cd2d2de.tar.gz
gentoo-f108551b0c1f39744cef0deab1b5184b7cd2d2de.tar.bz2
gentoo-f108551b0c1f39744cef0deab1b5184b7cd2d2de.zip
dev-util/makeheaders: add 0_p20220411
Signed-off-by: Eric Joldasov <bratishkaerik@getgoogleoff.me> Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'dev-util/makeheaders/makeheaders-0_p20220411.ebuild')
-rw-r--r--dev-util/makeheaders/makeheaders-0_p20220411.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-util/makeheaders/makeheaders-0_p20220411.ebuild b/dev-util/makeheaders/makeheaders-0_p20220411.ebuild
new file mode 100644
index 000000000000..f0e3367f1df4
--- /dev/null
+++ b/dev-util/makeheaders/makeheaders-0_p20220411.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+# https://fossil-scm.org/home/finfo?name=tools/makeheaders.c
+ARTIFACT_C="ca90c1e2460d79e48f97c2aac60a39bcb8024e394de7cff5164c9dcbc96ce529"
+# https://fossil-scm.org/home/finfo?name=tools/makeheaders.html
+ARTIFACT_HTML="262696252dc50250c896c90cc240dcd946614b9c7727902aa7606640507e9231"
+
+DESCRIPTION="Tool that automatically generates .h files for a C or C++ programming project"
+HOMEPAGE="https://www.hwaci.com/sw/mkhdr/"
+
+SRC_URI="
+ https://fossil-scm.org/home/raw/${ARTIFACT_C}?at=makeheaders.c -> makeheaders-${PV}.c
+ https://fossil-scm.org/home/raw/${ARTIFACT_HTML}?at=makeheaders.html -> makeheaders-${PV}.html
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+HTML_DOCS=( "makeheaders.html" )
+
+src_unpack() {
+ mkdir "${S}" || die
+ cp "${DISTDIR}"/makeheaders-${PV}.c "${S}/makeheaders.c" || die
+ cp "${DISTDIR}"/makeheaders-${PV}.html "${S}/makeheaders.html" || die
+}
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} -o makeheaders makeheaders.c || die
+}
+
+src_install() {
+ dobin makeheaders
+
+ einstalldocs
+}