summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-14 18:04:29 +0100
committerSam James <sam@gentoo.org>2023-05-14 18:10:33 +0100
commit797d8c8964adb5f41ad7d70c9137f61532733b43 (patch)
tree88dec67e1bcb7a9ec2536c326bf9c7ddbf39bd54 /dev-util/mdds
parentsci-libs/tensorpipe: enable cuda (diff)
downloadgentoo-797d8c8964adb5f41ad7d70c9137f61532733b43.tar.gz
gentoo-797d8c8964adb5f41ad7d70c9137f61532733b43.tar.bz2
gentoo-797d8c8964adb5f41ad7d70c9137f61532733b43.zip
dev-util/mdds: drop invalid USE=valgrind flag (for test suite)
We don't, in general, run Valgrind for test suites in Gentoo because it's not portable enough and gives inconsistent results, especially under sandbox. Plus it's confusing given USE=valgrind is effectively a global USE flag (even if it isn't in use.desc yet) for meaning "enable annotations to enable better debugging under Valgrind", rather than "run tests under it". Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/mdds')
-rw-r--r--dev-util/mdds/mdds-2.0.3.ebuild7
-rw-r--r--dev-util/mdds/mdds-9999.ebuild5
-rw-r--r--dev-util/mdds/metadata.xml3
3 files changed, 5 insertions, 10 deletions
diff --git a/dev-util/mdds/mdds-2.0.3.ebuild b/dev-util/mdds/mdds-2.0.3.ebuild
index 93686c75fc02..695e17e37bac 100644
--- a/dev-util/mdds/mdds-2.0.3.ebuild
+++ b/dev-util/mdds/mdds-2.0.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -17,7 +17,7 @@ HOMEPAGE="https://gitlab.com/mdds/mdds"
LICENSE="MIT"
SLOT="1/2.0" # Check API version on version bumps!
-IUSE="doc openmp valgrind test"
+IUSE="doc openmp test"
RESTRICT="!test? ( test )"
BDEPEND="
@@ -25,7 +25,6 @@ BDEPEND="
app-doc/doxygen
dev-python/sphinx
)
- valgrind? ( dev-util/valgrind )
"
DEPEND="dev-libs/boost:="
RDEPEND="${DEPEND}"
@@ -47,9 +46,9 @@ src_prepare() {
src_configure() {
local myeconfargs=(
+ --disable-memory_tests
$(use_enable doc docs)
$(use_enable openmp)
- $(use_enable valgrind memory_tests)
)
econf "${myeconfargs[@]}"
}
diff --git a/dev-util/mdds/mdds-9999.ebuild b/dev-util/mdds/mdds-9999.ebuild
index 6b1beb9c67a5..46c2ae14eb51 100644
--- a/dev-util/mdds/mdds-9999.ebuild
+++ b/dev-util/mdds/mdds-9999.ebuild
@@ -17,7 +17,7 @@ HOMEPAGE="https://gitlab.com/mdds/mdds"
LICENSE="MIT"
SLOT="1/2.1" # Check API version on version bumps!
-IUSE="doc openmp valgrind test"
+IUSE="doc openmp test"
RESTRICT="!test? ( test )"
DEPEND="dev-libs/boost:="
@@ -27,7 +27,6 @@ BDEPEND="
app-doc/doxygen
dev-python/sphinx
)
- valgrind? ( dev-util/valgrind )
"
PATCHES=( "${FILESDIR}/${PN}-1.5.0-buildsystem.patch" )
@@ -47,9 +46,9 @@ src_prepare() {
src_configure() {
local myeconfargs=(
+ --disable-memory_tests
$(use_enable doc docs)
$(use_enable openmp)
- $(use_enable valgrind memory_tests)
)
econf "${myeconfargs[@]}"
}
diff --git a/dev-util/mdds/metadata.xml b/dev-util/mdds/metadata.xml
index 9a508834b8a2..7710a5aad70e 100644
--- a/dev-util/mdds/metadata.xml
+++ b/dev-util/mdds/metadata.xml
@@ -8,7 +8,4 @@
<upstream>
<remote-id type="google-code">multidimalgorithm</remote-id>
</upstream>
- <use>
- <flag name="valgrind">Add support for memory debugging using <pkg>dev-util/valgrind</pkg></flag>
- </use>
</pkgmetadata>