summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilfried Holzke <gentoo@holzke.net>2020-12-28 10:42:03 +0100
committerCraig Andrews <candrews@gentoo.org>2020-12-28 12:24:11 -0500
commitc3877a5815fb63c7c885fc79d27d8346c1f4e6ce (patch)
treec7fd0b5f5c3e5467b90d109a769d2b116e759c62 /dev-util/rocm-smi/rocm-smi-4.0.0.ebuild
parentdev-libs/rapidjson: Drop dependency on valgrind; remove -march=native (diff)
downloadgentoo-c3877a5815fb63c7c885fc79d27d8346c1f4e6ce.tar.gz
gentoo-c3877a5815fb63c7c885fc79d27d8346c1f4e6ce.tar.bz2
gentoo-c3877a5815fb63c7c885fc79d27d8346c1f4e6ce.zip
dev-util/rocm-smi: ROCm System Management Interface
Signed-off-by: Wilfried Holzke <gentoo@holzke.net> Package-Manager: Portage-3.0.9, Repoman-3.0.2 Closes: https://github.com/gentoo/gentoo/pull/18848 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-util/rocm-smi/rocm-smi-4.0.0.ebuild')
-rw-r--r--dev-util/rocm-smi/rocm-smi-4.0.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/rocm-smi/rocm-smi-4.0.0.ebuild b/dev-util/rocm-smi/rocm-smi-4.0.0.ebuild
new file mode 100644
index 000000000000..3dd0188d8e67
--- /dev/null
+++ b/dev-util/rocm-smi/rocm-smi-4.0.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit python-single-r1
+
+DESCRIPTION="ROCm System Management Interface"
+HOMEPAGE="https://github.com/RadeonOpenCompute/ROC-smi"
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/RadeonOpenCompute/ROC-smi"
+ EGIT_BRANCH="master"
+else
+ SRC_URI="https://github.com/RadeonOpenCompute/ROC-smi/archive/rocm-${PV}.tar.gz -> rocm-smi-${PV}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/ROC-smi-rocm-${PV}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND=""
+RDEPEND="${PYTHON_DEPS}"
+
+src_install() {
+ python_scriptinto /usr/bin
+ python_newscript rocm_smi.py rocm-smi
+}