summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYiyangWu <xgreenlandforwyy@gmail.com>2021-08-19 22:30:23 +0800
committerCraig Andrews <candrews@gentoo.org>2021-08-19 15:46:23 -0400
commit89c4602e858ff22d0903f48953d33733760f190d (patch)
tree99154d6ab1633a2edbe85572d21c85b17749fbf3 /dev-util/rocminfo/rocminfo-4.3.0.ebuild
parentdev-libs/rocr-runtime: bump version to 4.3.0 (diff)
downloadgentoo-89c4602e858ff22d0903f48953d33733760f190d.tar.gz
gentoo-89c4602e858ff22d0903f48953d33733760f190d.tar.bz2
gentoo-89c4602e858ff22d0903f48953d33733760f190d.zip
dev-util/rocminfo: bump version to 4.3.0
Now it can also detect builtin amdgpu kernel module Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Yiyang Wu <xgreenlandforwyy@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/22034 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-util/rocminfo/rocminfo-4.3.0.ebuild')
-rw-r--r--dev-util/rocminfo/rocminfo-4.3.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-util/rocminfo/rocminfo-4.3.0.ebuild b/dev-util/rocminfo/rocminfo-4.3.0.ebuild
new file mode 100644
index 000000000000..ba629c1e3b72
--- /dev/null
+++ b/dev-util/rocminfo/rocminfo-4.3.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/RadeonOpenCompute/rocminfo/"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/RadeonOpenCompute/rocminfo/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/rocminfo-rocm-${PV}"
+fi
+
+DESCRIPTION="ROCm Application for Reporting System Info"
+HOMEPAGE="https://github.com/RadeonOpenCompute/rocminfo"
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+
+RDEPEND=">=dev-libs/rocr-runtime-${PV}"
+DEPEND="${RDEPEND}"
+
+PATCHES=("${FILESDIR}/${PN}-4.3.0-detect-builtin-amdgpu.patch")