summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2024-05-15 22:04:43 +0200
committerSam James <sam@gentoo.org>2024-06-01 04:06:12 +0100
commit309054901eb0b981308385ff71358c325978f26e (patch)
treed0c233c9cd2903fe198defd2a4134d4401b3f7a7 /dev-util/ropper
parentdev-db/sqlmap: drop 1.7.9, 1.8 (diff)
downloadgentoo-309054901eb0b981308385ff71358c325978f26e.tar.gz
gentoo-309054901eb0b981308385ff71358c325978f26e.tar.bz2
gentoo-309054901eb0b981308385ff71358c325978f26e.zip
dev-util/ropper: add 1.13.10
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/ropper')
-rw-r--r--dev-util/ropper/Manifest1
-rw-r--r--dev-util/ropper/ropper-1.13.10.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-util/ropper/Manifest b/dev-util/ropper/Manifest
index f84be37d3a73..1adab485dfa4 100644
--- a/dev-util/ropper/Manifest
+++ b/dev-util/ropper/Manifest
@@ -1 +1,2 @@
+DIST ropper-1.13.10.gh.tar.gz 1492233 BLAKE2B c7b385fc2cf9f0777394899910d9433c09b9df0b5ba489b4fac71be3fbeeb4c1d68bdace6dcefb114aad3f89452745d04351a85003998bf3f8b148a774ea7a5a SHA512 64afab433a633f10bb964af44e51c5d44885e03c718695284c3cfd73ea3f204561224d26575e1e376ca0c1424fe6ca859c5844a55798375223ea304e455d8c04
DIST ropper-1.13.8.gh.tar.gz 1491769 BLAKE2B 8601bcd2287763aa208b227c437362b9799ec1775104b659213e69a77f118bce567e95a0b83a4f0556439a82ee853ebc9aabaa4098b2a700572d1b661213eb25 SHA512 eae2279e1c6bc91af76e8e5d37b7d57c5d2e518d027e293dbd52c6c27dcd8826e73673c55fe581cdefda272b657c8eff2b5eb4fdc4996fec1548709b8371b5d4
diff --git a/dev-util/ropper/ropper-1.13.10.ebuild b/dev-util/ropper/ropper-1.13.10.ebuild
new file mode 100644
index 000000000000..c65ff227aaa9
--- /dev/null
+++ b/dev-util/ropper/ropper-1.13.10.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Use to display information about binary files in different file formats"
+HOMEPAGE="https://scoding.de/ropper https://github.com/sashs/Ropper"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/sashs/Ropper"
+else
+ SRC_URI="https://github.com/sashs/Ropper/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ S="${WORKDIR}"/Ropper-${PV}
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="z3"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-libs/capstone[python,${PYTHON_USEDEP}]
+ dev-libs/keystone[python,${PYTHON_USEDEP}]
+ dev-python/filebytes[${PYTHON_USEDEP}]
+ ')
+ z3? ( sci-mathematics/z3[python,${PYTHON_SINGLE_USEDEP}] )
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # Remove test which dies on trying to import itself (stub loader, not a real test)
+ rm test.py || die
+
+ distutils-r1_src_prepare
+}