summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-08-27 09:22:09 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-08-27 09:46:45 +0300
commit3aee4a342f0270b809e0c613c09762f8694c9b00 (patch)
tree86989bf56ce95f11c60995c9a1d49b67670fdc51 /dev-util/shunit2/shunit2-2.1.8.ebuild
parentdev-util/shunit2: add myself as a maintainer (diff)
downloadgentoo-3aee4a342f0270b809e0c613c09762f8694c9b00.tar.gz
gentoo-3aee4a342f0270b809e0c613c09762f8694c9b00.tar.bz2
gentoo-3aee4a342f0270b809e0c613c09762f8694c9b00.zip
dev-util/shunit2: add 2.1.8
- Add test - Change LICENSE to Apache-2.0 - EAPI=8 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-util/shunit2/shunit2-2.1.8.ebuild')
-rw-r--r--dev-util/shunit2/shunit2-2.1.8.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-util/shunit2/shunit2-2.1.8.ebuild b/dev-util/shunit2/shunit2-2.1.8.ebuild
new file mode 100644
index 000000000000..34e9c4ad0714
--- /dev/null
+++ b/dev-util/shunit2/shunit2-2.1.8.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Unit-test framework for Bourne-based shell scripts"
+HOMEPAGE="https://github.com/kward/shunit2"
+SRC_URI="https://github.com/kward/shunit2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ app-shells/dash
+ app-shells/ksh
+ app-shells/zsh
+ )
+"
+
+src_test() {
+ rm shunit2_macros_test.sh || die
+ ./test_runner || die
+}
+
+src_install() {
+ dobin shunit2
+
+ # For backwards compat to <=2.1.5
+ dosym -r /usr/bin/shunit2 /usr/share/shunit2/shunit2
+
+ dodoc -r examples
+ dodoc doc/*.txt
+}