summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2019-04-13 16:07:10 +0200
committerTiziano Müller <dev-zero@gentoo.org>2019-04-13 16:08:18 +0200
commit94686e9c582faa576804c20a0e2e037f701f8f5b (patch)
treee6813e8809685cb8dcf9ed20e7f0903ee710bff9 /dev-util/source-highlight
parentdev-util/debugedit: amd64 stable wrt bug #683222 (diff)
downloadgentoo-94686e9c582faa576804c20a0e2e037f701f8f5b.tar.gz
gentoo-94686e9c582faa576804c20a0e2e037f701f8f5b.tar.bz2
gentoo-94686e9c582faa576804c20a0e2e037f701f8f5b.zip
dev-util/source-highlight: fix dark colors in GDB
rev.bump to import patch from Fedora (and bump EAPI) to make functions names readable in syntax colored GDB output when using a dark background, see https://bugzilla.redhat.com/show_bug.cgi?id=1688372 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Tiziano Müller <dev-zero@gentoo.org>
Diffstat (limited to 'dev-util/source-highlight')
-rw-r--r--dev-util/source-highlight/files/source-highlight-3.1.8-no-black.patch12
-rw-r--r--dev-util/source-highlight/source-highlight-3.1.8-r1.ebuild55
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-util/source-highlight/files/source-highlight-3.1.8-no-black.patch b/dev-util/source-highlight/files/source-highlight-3.1.8-no-black.patch
new file mode 100644
index 000000000000..b673c2f79221
--- /dev/null
+++ b/dev-util/source-highlight/files/source-highlight-3.1.8-no-black.patch
@@ -0,0 +1,12 @@
+diff -up source-highlight-3.1.8/src/esc.style.no-black source-highlight-3.1.8/src/esc.style
+--- source-highlight-3.1.8/src/esc.style.no-black 2019-03-20 16:52:33.053965325 +0000
++++ source-highlight-3.1.8/src/esc.style 2019-03-20 16:52:42.502965289 +0000
+@@ -7,7 +7,7 @@ comment cyan i ;
+ number purple ;
+ preproc darkblue b ;
+ symbol darkred ;
+-function black b;
++function b;
+ cbracket red;
+ variable darkgreen ;
+
diff --git a/dev-util/source-highlight/source-highlight-3.1.8-r1.ebuild b/dev-util/source-highlight/source-highlight-3.1.8-r1.ebuild
new file mode 100644
index 000000000000..2d1d48d60339
--- /dev/null
+++ b/dev-util/source-highlight/source-highlight-3.1.8-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 flag-o-matic
+
+DESCRIPTION="Generate highlighted source code as an (x)html document"
+HOMEPAGE="https://www.gnu.org/software/src-highlite/source-highlight.html"
+SRC_URI="mirror://gnu/src-highlite/${P}.tar.gz"
+LICENSE="GPL-3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+SLOT="0"
+IUSE="doc static-libs"
+
+RDEPEND=">=dev-libs/boost-1.62.0:=[threads]
+ dev-util/ctags"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+PATCHES=(
+ "${FILESDIR}/${P}-no-black.patch"
+ )
+
+src_configure() {
+ # required as rev-dep of dev-libs/boost-1.62.0
+ # https://wiki.gentoo.org/wiki/Project:C%2B%2B/Maintaining_ABI
+ append-cxxflags -std=c++14
+
+ econf \
+ --with-boost="${EPREFIX}/usr" \
+ --with-boost-regex="boost_regex" \
+ --without-bash-completion \
+ $(use_enable static-libs static)
+}
+
+src_install () {
+ use doc && local HTML_DOCS=( doc/*.{html,css,java} )
+ default
+
+ # That's not how we want it
+ rm -rf "${ED%/}"/usr/share/{aclocal,doc} || die
+
+ # package provides .pc file
+ find "${D}" -name '*.la' -delete || die
+
+ dobashcomp completion/source-highlight
+}
+
+src_test() {
+ export LD_LIBRARY_PATH="${S}/lib/srchilite/.libs/"
+ # upstream uses the same temporary filenames in numerous places
+ # see https://bugs.gentoo.org/635100
+ emake -j1 check
+}