summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Sarnie <commendsarnex@gmail.com>2018-03-12 21:10:01 -0400
committerMatt Turner <mattst88@gentoo.org>2018-03-23 16:36:11 -0700
commit9c4878c78c9481ea62e0a6665f0409fc06afd170 (patch)
treeba568ce68f258f111fc14371a3f743cc7a65e99e /dev-util/spirv-tools/spirv-tools-9999.ebuild
parentdev-util/spirv-headers: Initial versions (diff)
downloadgentoo-9c4878c78c9481ea62e0a6665f0409fc06afd170.tar.gz
gentoo-9c4878c78c9481ea62e0a6665f0409fc06afd170.tar.bz2
gentoo-9c4878c78c9481ea62e0a6665f0409fc06afd170.zip
dev-util/spirv-tools: Initial Versions
Signed-off-by: Nick Sarnie <commendsarnex@gmail.com>
Diffstat (limited to 'dev-util/spirv-tools/spirv-tools-9999.ebuild')
-rw-r--r--dev-util/spirv-tools/spirv-tools-9999.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-util/spirv-tools/spirv-tools-9999.ebuild b/dev-util/spirv-tools/spirv-tools-9999.ebuild
new file mode 100644
index 000000000000..e6ecb91d83e6
--- /dev/null
+++ b/dev-util/spirv-tools/spirv-tools-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-multilib cmake-utils git-r3
+
+DESCRIPTION="Provides an API and commands for processing SPIR-V modules"
+HOMEPAGE="https://github.com/KhronosGroup/SPIRV-Tools"
+EGIT_REPO_URI="https://github.com/KhronosGroup/SPIRV-Tools.git"
+SRC_URI=""
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND=""
+DEPEND="dev-util/spirv-headers"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ "-DSPIRV-Headers_SOURCE_DIR=/usr/"
+ )
+
+ cmake-utils_src_configure
+}