summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-04-27 14:07:03 +0200
committerLars Wendler <polynomial-c@gentoo.org>2021-04-27 14:09:48 +0200
commitb1afaaf9486e0c68ec04bcd6c4f50ac05b8bc4f1 (patch)
tree2c88613680174565311dfc873889c05f6817358a /dev-util/strace
parentdev-util/strace: Synced live ebuild (diff)
downloadgentoo-b1afaaf9486e0c68ec04bcd6c4f50ac05b8bc4f1.tar.gz
gentoo-b1afaaf9486e0c68ec04bcd6c4f50ac05b8bc4f1.tar.bz2
gentoo-b1afaaf9486e0c68ec04bcd6c4f50ac05b8bc4f1.zip
dev-util/strace: Removed old
Closes: https://github.com/gentoo/gentoo/pull/20356 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-util/strace')
-rw-r--r--dev-util/strace/Manifest2
-rw-r--r--dev-util/strace/strace-5.10.ebuild104
-rw-r--r--dev-util/strace/strace-5.8.ebuild104
3 files changed, 0 insertions, 210 deletions
diff --git a/dev-util/strace/Manifest b/dev-util/strace/Manifest
index 628828bba363..c309375d1faf 100644
--- a/dev-util/strace/Manifest
+++ b/dev-util/strace/Manifest
@@ -1,4 +1,2 @@
-DIST strace-5.10.tar.xz 1859688 BLAKE2B 45c40854c9af95395cb274fbfddc3d0084e77cc403ffe104f72ce7592800452776f5c19d03649cdd6705bccc7a0859364e470bdd5344f64af54b798fab50475e SHA512 1baa41b6d52f2e40e42a22850beee1ae278fafe712796694631898f06a7540d8f2c3fa70807e0062734f0976ebbd0824457c733ccda248f017c218387366ed48
DIST strace-5.11.tar.xz 1926632 BLAKE2B df47612c0928466f8b5788c4a7dc74208fe76c6967d3219b0eb753131fba315e715626c2cd1ed56d3e8ba0eb9a338589a8cbd6205fe876123ac26fdf0fab8d31 SHA512 688bec8d620c7ca701561ed7479e42687cc30737f944b82201731d827775cd2864787ecca7c93ba149b06d5d654d9f6bd109a977f8138bab34339cd5930828f0
DIST strace-5.12.tar.xz 2009060 BLAKE2B 9a7a07e5d2d38c8b456f54d0e1d7c776066b20327fa08d562e426a7096f708dffa00f0c2121683fa71f7029db958d450c5a6abf5ae5970dc02732f5aa7cef591 SHA512 289cf82da4c69270458953b45d09c8eb05a6624898d3ac493c3ec293cd5ad07205084ad0af021dab2be9c0dc53f0301816113a746d96c78780b79231a185e7c9
-DIST strace-5.8.tar.xz 1813640 BLAKE2B 315edf404fa57890dcff512f9fd76818e8e7d5ad06bc297b68561ec7073297c2e5aaf2c3d9a102382f5833bedacb2a54540068a9f9438094c9180f45b5dc4715 SHA512 633c3daa2dd3d273839cbb8ebd7f6512a38b39af0d0d89f4676c2067e199f346615406d85e3e13f9e4da8dbeb62095185895ffae986eb99b64775a4287e38f4c
diff --git a/dev-util/strace/strace-5.10.ebuild b/dev-util/strace/strace-5.10.ebuild
deleted file mode 100644
index c08dbf18c0a5..000000000000
--- a/dev-util/strace/strace-5.10.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools flag-o-matic toolchain-funcs
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/strace/strace.git"
- inherit git-r3 autotools
-else
- SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
-fi
-
-DESCRIPTION="A useful diagnostic, instructional, and debugging tool"
-HOMEPAGE="https://strace.io/"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="aio perl static unwind elfutils"
-
-REQUIRED_USE="?? ( unwind elfutils )"
-
-BDEPEND="
- virtual/pkgconfig
-"
-LIB_DEPEND="
- unwind? ( sys-libs/libunwind[static-libs(+)] )
- elfutils? ( dev-libs/elfutils[static-libs(+)] )
-"
-# strace only uses the header from libaio to decode structs
-DEPEND="
- static? ( ${LIB_DEPEND} )
- aio? ( >=dev-libs/libaio-0.3.106 )
- sys-kernel/linux-headers
-"
-RDEPEND="
- !static? ( ${LIB_DEPEND//\[static-libs(+)]} )
- perl? ( dev-lang/perl )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-5.5-static.patch"
-)
-
-src_prepare() {
- default
-
- eautoreconf
-
- if [[ ! -e configure ]] ; then
- # git generation
- sed /autoreconf/d -i bootstrap || die
- ./bootstrap || die
- eautoreconf
- [[ ! -e CREDITS ]] && cp CREDITS{.in,}
- fi
-
- filter-lfs-flags # configure handles this sanely
-
- export ac_cv_header_libaio_h=$(usex aio)
- use elibc_musl && export ac_cv_header_stdc=no
-
- # Stub out the -k test since it's known to be flaky. #545812
- sed -i '1iexit 77' tests*/strace-k.test || die
-}
-
-src_configure() {
- # Set up the default build settings, and then use the names strace expects.
- tc-export_build_env BUILD_{CC,CPP}
- local v bv
- for v in CC CPP {C,CPP,LD}FLAGS ; do
- bv="BUILD_${v}"
- export "${v}_FOR_BUILD=${!bv}"
- done
-
- # Don't require mpers support on non-multilib systems. #649560
- local myeconfargs=(
- --disable-gcc-Werror
- --enable-mpers=check
- $(use_enable static)
- $(use_with unwind libunwind)
- $(use_with elfutils libdw)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_test() {
- if has usersandbox ${FEATURES} ; then
- ewarn "Test suite is known to fail with FEATURES=usersandbox -- skipping ..." #643044
- return 0
- fi
-
- default
-}
-
-src_install() {
- default
- if ! use perl ; then
- rm "${ED}"/usr/bin/strace-graph || die
- fi
- dodoc CREDITS
-}
diff --git a/dev-util/strace/strace-5.8.ebuild b/dev-util/strace/strace-5.8.ebuild
deleted file mode 100644
index c6e695ce32de..000000000000
--- a/dev-util/strace/strace-5.8.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools flag-o-matic toolchain-funcs
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/strace/strace.git"
- inherit git-r3 autotools
-else
- SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-fi
-
-DESCRIPTION="A useful diagnostic, instructional, and debugging tool"
-HOMEPAGE="https://strace.io/"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="aio perl static unwind elfutils"
-
-REQUIRED_USE="?? ( unwind elfutils )"
-
-BDEPEND="
- virtual/pkgconfig
-"
-LIB_DEPEND="
- unwind? ( sys-libs/libunwind[static-libs(+)] )
- elfutils? ( dev-libs/elfutils[static-libs(+)] )
-"
-# strace only uses the header from libaio to decode structs
-DEPEND="
- static? ( ${LIB_DEPEND} )
- aio? ( >=dev-libs/libaio-0.3.106 )
- sys-kernel/linux-headers
-"
-RDEPEND="
- !static? ( ${LIB_DEPEND//\[static-libs(+)]} )
- perl? ( dev-lang/perl )
-"
-
-PATCHES=(
- "${FILESDIR}/strace-5.5-static.patch"
-)
-
-src_prepare() {
- default
-
- eautoreconf
-
- if [[ ! -e configure ]] ; then
- # git generation
- sed /autoreconf/d -i bootstrap || die
- ./bootstrap || die
- eautoreconf
- [[ ! -e CREDITS ]] && cp CREDITS{.in,}
- fi
-
- filter-lfs-flags # configure handles this sanely
-
- export ac_cv_header_libaio_h=$(usex aio)
- use elibc_musl && export ac_cv_header_stdc=no
-
- # Stub out the -k test since it's known to be flaky. #545812
- sed -i '1iexit 77' tests*/strace-k.test || die
-}
-
-src_configure() {
- # Set up the default build settings, and then use the names strace expects.
- tc-export_build_env BUILD_{CC,CPP}
- local v bv
- for v in CC CPP {C,CPP,LD}FLAGS ; do
- bv="BUILD_${v}"
- export "${v}_FOR_BUILD=${!bv}"
- done
-
- # Don't require mpers support on non-multilib systems. #649560
- local myeconfargs=(
- --disable-gcc-Werror
- --enable-mpers=check
- $(use_enable static)
- $(use_with unwind libunwind)
- $(use_with elfutils libdw)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_test() {
- if has usersandbox ${FEATURES} ; then
- ewarn "Test suite is known to fail with FEATURES=usersandbox -- skipping ..." #643044
- return 0
- fi
-
- default
-}
-
-src_install() {
- default
- if ! use perl ; then
- rm "${ED}"/usr/bin/strace-graph || die
- fi
- dodoc CREDITS
-}