summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-11 15:20:52 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-11 15:31:51 +0100
commit4e5b7e7738ad18b113fb61a678b05444aeafd5d5 (patch)
tree1cec866f831270bfeddd337a3eef4d0b7f6f0726 /dev-util/stripe-mock
parentdev-python/sphinx_ansible_theme: Bump to 0.10.0 (diff)
downloadgentoo-4e5b7e7738ad18b113fb61a678b05444aeafd5d5.tar.gz
gentoo-4e5b7e7738ad18b113fb61a678b05444aeafd5d5.tar.bz2
gentoo-4e5b7e7738ad18b113fb61a678b05444aeafd5d5.zip
dev-util/stripe-mock: Bump to 0.145.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/stripe-mock')
-rw-r--r--dev-util/stripe-mock/Manifest1
-rw-r--r--dev-util/stripe-mock/stripe-mock-0.145.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/stripe-mock/Manifest b/dev-util/stripe-mock/Manifest
index c2aadf0a6153..41d872d9688a 100644
--- a/dev-util/stripe-mock/Manifest
+++ b/dev-util/stripe-mock/Manifest
@@ -1 +1,2 @@
DIST stripe-mock-0.141.0.tar.gz 583884 BLAKE2B bd6e8c19280047fe0aba420aa701e1d7df340d10c1a16f03ae46c690f1c77ea59413f0911c44d71542ef6cc6d8ae7474905b4a997714f1dc30e42b20f8dbe64f SHA512 11083ccb14cba1fdcd629d22ad663c88bd7b0d37274e86f178f7cf0fe789ca3bd52a1f4ab9f2414ecee7590124d69e6a2813221dbfd0d74cc86e454157dbefc5
+DIST stripe-mock-0.145.0.tar.gz 579773 BLAKE2B f2661daf70f2073ce475b53e591d08ddb030e263c0b08211083f675ced05842e92d43c16183369658d32abed5569b48695e300f26b491f10983bcc6ec41a9e74 SHA512 55597c4911ef32c804a63289cc9d04c5ed4f6b673cdd85e794a039abab8b6741e6970d13f8c54c3734d1ed2948437d4ebfdb0ef45bd12dcabee530ae9baaae66
diff --git a/dev-util/stripe-mock/stripe-mock-0.145.0.ebuild b/dev-util/stripe-mock/stripe-mock-0.145.0.ebuild
new file mode 100644
index 000000000000..89958510a463
--- /dev/null
+++ b/dev-util/stripe-mock/stripe-mock-0.145.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Mock HTTP server that responds like the real Stripe API"
+HOMEPAGE="https://github.com/stripe/stripe-mock/"
+SRC_URI="https://github.com/stripe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT ISC BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_compile() {
+ emake build
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ dobin stripe-mock
+ einstalldocs
+}