summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/systemtap
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/systemtap')
-rw-r--r--dev-util/systemtap/Manifest2
-rw-r--r--dev-util/systemtap/metadata.xml7
-rw-r--r--dev-util/systemtap/systemtap-2.4-r1.ebuild71
-rw-r--r--dev-util/systemtap/systemtap-2.4.ebuild69
-rw-r--r--dev-util/systemtap/systemtap-2.5.ebuild71
5 files changed, 220 insertions, 0 deletions
diff --git a/dev-util/systemtap/Manifest b/dev-util/systemtap/Manifest
new file mode 100644
index 000000000000..2b5aa57a0ae0
--- /dev/null
+++ b/dev-util/systemtap/Manifest
@@ -0,0 +1,2 @@
+DIST systemtap-2.4.tar.gz 2664988 SHA256 fdcee37c4db188819a69f67a72ad1977251e80673cebf729a443b6c00be779f4 SHA512 40c30942eb50948f11f06f9f37c76d96f5ebc8eb6d164c9af5d54845b3f43f38594ddebf5f0d42ac4704b0a2563cd23edf818c196ee1330db00011a85ae11b0c WHIRLPOOL 7441504b167b9f90da52abb7f0c934263c9ce984de4caedc43f3694c7a1c492fe7c5bdd56357d7eebc8d306aea6873cdf8c0dadb0fafcc4f0bb192d5e9cfb9d3
+DIST systemtap-2.5.tar.gz 2767649 SHA256 fdd9e2c6f6325790d3c6c68ada8fa895babbecc1ed7c9e531080e946c2eef075 SHA512 17d64bf19ae72e935b715e72c04802db32453ef49afcbb8bbdad898a654bf3a5e66c68baaf8bc3c877000c1b28c865043c954d33e8d8588e894f7dda405aa0df WHIRLPOOL 4e7e810cb7e6fc735bcfc8d00455091d04ee22b91bf3738f918a8d7b672917f0c30d4fe17540cceba778fe76735e5ae6ebc703b401d5fb09420c6cb56ba903bf
diff --git a/dev-util/systemtap/metadata.xml b/dev-util/systemtap/metadata.xml
new file mode 100644
index 000000000000..169842617ecf
--- /dev/null
+++ b/dev-util/systemtap/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>swegener@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-util/systemtap/systemtap-2.4-r1.ebuild b/dev-util/systemtap/systemtap-2.4-r1.ebuild
new file mode 100644
index 000000000000..52ce740ddf72
--- /dev/null
+++ b/dev-util/systemtap/systemtap-2.4-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit linux-info autotools eutils python-single-r1
+
+DESCRIPTION="A linux trace/probe tool"
+HOMEPAGE="http://www.sourceware.org/systemtap/"
+SRC_URI="http://www.sourceware.org/${PN}/ftp/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ~mips ppc ppc64 ~s390 sparc x86"
+IUSE="sqlite"
+
+RDEPEND=">=dev-libs/elfutils-0.142
+ sys-libs/libcap
+ ${PYTHON_DEPS}
+ sqlite? ( dev-db/sqlite:3 )"
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.18.2"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+CONFIG_CHECK="~KPROBES ~RELAY ~DEBUG_FS"
+ERROR_KPROBES="${PN} requires support for KProbes Instrumentation (KPROBES) - this can be enabled in 'Instrumentation Support -> Kprobes'."
+ERROR_RELAY="${PN} works with support for user space relay support (RELAY) - this can be enabled in 'General setup -> Kernel->user space relay support (formerly relayfs)'."
+ERROR_DEBUG_FS="${PN} works best with support for Debug Filesystem (DEBUG_FS) - this can be enabled in 'Kernel hacking -> Debug Filesystem'."
+
+DOCS="AUTHORS HACKING NEWS README"
+
+pkg_setup() {
+ linux-info_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ python_fix_shebang .
+
+ sed -i \
+ -e 's:-Werror::g' \
+ configure.ac \
+ Makefile.am \
+ staprun/Makefile.am \
+ stapdyn/Makefile.am \
+ buildrun.cxx \
+ testsuite/systemtap.unprivileged/unprivileged_probes.exp \
+ testsuite/systemtap.unprivileged/unprivileged_myproc.exp \
+ testsuite/systemtap.base/stmt_rel_user.exp \
+ testsuite/systemtap.base/sdt_va_args.exp \
+ testsuite/systemtap.base/sdt_misc.exp \
+ testsuite/systemtap.base/sdt.exp \
+ scripts/kprobes_test/gen_code.py \
+ || die "Failed to clean up sources"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --without-rpm \
+ --disable-server \
+ --disable-docs \
+ --disable-refdocs \
+ --disable-grapher \
+ $(use_enable sqlite)
+}
diff --git a/dev-util/systemtap/systemtap-2.4.ebuild b/dev-util/systemtap/systemtap-2.4.ebuild
new file mode 100644
index 000000000000..852b62f0b42a
--- /dev/null
+++ b/dev-util/systemtap/systemtap-2.4.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+
+inherit linux-info autotools eutils python
+
+DESCRIPTION="A linux trace/probe tool"
+HOMEPAGE="http://www.sourceware.org/systemtap/"
+SRC_URI="http://www.sourceware.org/${PN}/ftp/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc x86"
+IUSE="sqlite"
+
+RDEPEND=">=dev-libs/elfutils-0.142
+ sys-libs/libcap
+ sqlite? ( dev-db/sqlite:3 )"
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.18.2"
+
+CONFIG_CHECK="~KPROBES ~RELAY ~DEBUG_FS"
+ERROR_KPROBES="${PN} requires support for KProbes Instrumentation (KPROBES) - this can be enabled in 'Instrumentation Support -> Kprobes'."
+ERROR_RELAY="${PN} works with support for user space relay support (RELAY) - this can be enabled in 'General setup -> Kernel->user space relay support (formerly relayfs)'."
+ERROR_DEBUG_FS="${PN} works best with support for Debug Filesystem (DEBUG_FS) - this can be enabled in 'Kernel hacking -> Debug Filesystem'."
+
+DOCS="AUTHORS HACKING NEWS README"
+
+pkg_setup() {
+ linux-info_pkg_setup
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_convert_shebangs 2 dtrace.in
+
+ sed -i \
+ -e 's:-Werror::g' \
+ configure.ac \
+ Makefile.am \
+ staprun/Makefile.am \
+ stapdyn/Makefile.am \
+ buildrun.cxx \
+ testsuite/systemtap.unprivileged/unprivileged_probes.exp \
+ testsuite/systemtap.unprivileged/unprivileged_myproc.exp \
+ testsuite/systemtap.base/stmt_rel_user.exp \
+ testsuite/systemtap.base/sdt_va_args.exp \
+ testsuite/systemtap.base/sdt_misc.exp \
+ testsuite/systemtap.base/sdt.exp \
+ scripts/kprobes_test/gen_code.py \
+ || die "Failed to clean up sources"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --without-rpm \
+ --disable-server \
+ --disable-docs \
+ --disable-refdocs \
+ --disable-grapher \
+ $(use_enable sqlite)
+}
diff --git a/dev-util/systemtap/systemtap-2.5.ebuild b/dev-util/systemtap/systemtap-2.5.ebuild
new file mode 100644
index 000000000000..e2e948e66a95
--- /dev/null
+++ b/dev-util/systemtap/systemtap-2.5.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit linux-info autotools eutils python-single-r1
+
+DESCRIPTION="A linux trace/probe tool"
+HOMEPAGE="http://www.sourceware.org/systemtap/"
+SRC_URI="http://www.sourceware.org/${PN}/ftp/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="sqlite"
+
+RDEPEND=">=dev-libs/elfutils-0.142
+ sys-libs/libcap
+ ${PYTHON_DEPS}
+ sqlite? ( dev-db/sqlite:3 )"
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.18.2"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+CONFIG_CHECK="~KPROBES ~RELAY ~DEBUG_FS"
+ERROR_KPROBES="${PN} requires support for KProbes Instrumentation (KPROBES) - this can be enabled in 'Instrumentation Support -> Kprobes'."
+ERROR_RELAY="${PN} works with support for user space relay support (RELAY) - this can be enabled in 'General setup -> Kernel->user space relay support (formerly relayfs)'."
+ERROR_DEBUG_FS="${PN} works best with support for Debug Filesystem (DEBUG_FS) - this can be enabled in 'Kernel hacking -> Debug Filesystem'."
+
+DOCS="AUTHORS HACKING NEWS README"
+
+pkg_setup() {
+ linux-info_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ python_fix_shebang .
+
+ sed -i \
+ -e 's:-Werror::g' \
+ configure.ac \
+ Makefile.am \
+ staprun/Makefile.am \
+ stapdyn/Makefile.am \
+ buildrun.cxx \
+ testsuite/systemtap.unprivileged/unprivileged_probes.exp \
+ testsuite/systemtap.unprivileged/unprivileged_myproc.exp \
+ testsuite/systemtap.base/stmt_rel_user.exp \
+ testsuite/systemtap.base/sdt_va_args.exp \
+ testsuite/systemtap.base/sdt_misc.exp \
+ testsuite/systemtap.base/sdt.exp \
+ scripts/kprobes_test/gen_code.py \
+ || die "Failed to clean up sources"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --without-rpm \
+ --disable-server \
+ --disable-docs \
+ --disable-refdocs \
+ --disable-grapher \
+ $(use_enable sqlite)
+}