summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-06-22 22:16:08 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-06-22 22:16:21 +0100
commit0722911b79f21d7c5d574758ae147934aa5a992c (patch)
tree0349ae370f795a15d68209bf2a9461f08b5c9481 /dev-util
parentdev-libs/opencl-clang:10: Remove BDEPEND="dev-vcs/git" (diff)
downloadgentoo-0722911b79f21d7c5d574758ae147934aa5a992c.tar.gz
gentoo-0722911b79f21d7c5d574758ae147934aa5a992c.tar.bz2
gentoo-0722911b79f21d7c5d574758ae147934aa5a992c.zip
dev-util/ccache: bump up to 3.7.10
Among other things new ccache improves handling of profile handling on clang. Should help for cases like bug #718632 Reported-by: Thomas Deutschmann Bug: https://bugs.gentoo.org/718632 Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/ccache/Manifest1
-rw-r--r--dev-util/ccache/ccache-3.7.10.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-util/ccache/Manifest b/dev-util/ccache/Manifest
index e5af79225a78..3e63a2bd6538 100644
--- a/dev-util/ccache/Manifest
+++ b/dev-util/ccache/Manifest
@@ -1,2 +1,3 @@
+DIST ccache-3.7.10.tar.xz 353792 BLAKE2B d7c06ee55a79afb4b72cdc20ec3d6413a5417301c63a0c822a4f82e6b9542c7a9cdf9f1bbd60a4698c335fdddfadcb9d674bff02c6dad1c2df9932212fdf6477 SHA512 64b0d42af7fd2dfdda65668b04dbd16807a22324e336e61f6c6a91c00110fb535c7ac9062a9c14c924a7ddaf42247f69a43d83dd0fd187ce3b0737158b5bb8fc
DIST ccache-3.7.7.tar.xz 351592 BLAKE2B 0b211cb77ceb42b7ee5dfcde98d9f53bf222cf18b8d38a7cf6fc9631c5e1c79ca82e6d0a0dbacfe2d5f61b2acefebe202e06fc3b8035f0f25a5f9954554a18cd SHA512 f93380aeb45e815964abc3b62f1963abafe22e0c6a7b61d039e710c7f935221e02678e21af65add4fd59fd5a141824ab95f4a7afc8dd557de36737c365cab816
DIST ccache-3.7.9.tar.xz 352948 BLAKE2B 791491c3f9da58f06bb0a58e411d9a7b3e39e460102793ef736820913d43d488ce7daffba572c21f507ea78d8da04edc3aaa47eb1a0fbec8cb35461a60b770e9 SHA512 5d39baeb66265451b0e9cef250f6d9c5f6869cd87e27c108c9a50bef80050122ed4280ff662a81bba8d1d1311f2004bcaf9ada6b783a42eedc67ca01ebc48bb4
diff --git a/dev-util/ccache/ccache-3.7.10.ebuild b/dev-util/ccache/ccache-3.7.10.ebuild
new file mode 100644
index 000000000000..32f24f67e079
--- /dev/null
+++ b/dev-util/ccache/ccache-3.7.10.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="fast compiler cache"
+HOMEPAGE="https://ccache.dev/"
+SRC_URI="https://github.com/ccache/ccache/releases/download/v${PV}/ccache-${PV}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="test"
+
+DEPEND="app-arch/xz-utils
+ sys-libs/zlib"
+RDEPEND="${DEPEND}
+ dev-util/shadowman
+ sys-apps/gentoo-functions"
+# clang-specific tests use dev-libs/elfutils to compare objects for equality.
+# Let's pull in the dependency unconditionally.
+DEPEND+="
+ test? ( dev-libs/elfutils )"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.5-nvcc-test.patch
+)
+
+src_prepare() {
+ default
+
+ sed \
+ -e "/^EPREFIX=/s:'':'${EPREFIX}':" \
+ "${FILESDIR}"/ccache-config-3 > ccache-config || die
+}
+
+src_configure() {
+ econf --without-bundled-zlib
+}
+
+src_compile() {
+ emake V=1
+}
+
+src_test() {
+ emake check V=1
+}
+
+src_install() {
+ DOCS=( doc/{AUTHORS,MANUAL,NEWS}.adoc CONTRIBUTING.md README.md )
+ default
+
+ dobin ccache-config
+ insinto /usr/share/shadowman/tools
+ newins - ccache <<<"${EPREFIX}/usr/lib/ccache/bin"
+}
+
+pkg_prerm() {
+ if [[ -z ${REPLACED_BY_VERSION} && ${ROOT:-/} == / ]] ; then
+ eselect compiler-shadow remove ccache
+ fi
+}
+
+pkg_postinst() {
+ if [[ ${ROOT:-/} == / ]]; then
+ eselect compiler-shadow update ccache
+ fi
+}