summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-14 20:20:29 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-14 20:21:20 +0200
commit0899b9d40f77f7f99c90ebfba808cba0774c4752 (patch)
tree30fa36cd71f2dc5e1508908e22472b4b16b305c6 /dev-util
parentdev-util/gi-docgen: Add PyPI remote-id (diff)
downloadgentoo-0899b9d40f77f7f99c90ebfba808cba0774c4752.tar.gz
gentoo-0899b9d40f77f7f99c90ebfba808cba0774c4752.tar.bz2
gentoo-0899b9d40f77f7f99c90ebfba808cba0774c4752.zip
dev-util/gi-docgen: Bump to 2023.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/gi-docgen/Manifest1
-rw-r--r--dev-util/gi-docgen/gi-docgen-2023.3.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-util/gi-docgen/Manifest b/dev-util/gi-docgen/Manifest
index 9b55bb19e11a..ba26292ad43b 100644
--- a/dev-util/gi-docgen/Manifest
+++ b/dev-util/gi-docgen/Manifest
@@ -1 +1,2 @@
DIST gi-docgen-2023.1.tar.gz 2516453 BLAKE2B d97ca86f1e9c29de3b1500a08b93a1617dddfc6f29314f1d0f1cbd3ec7b367f4de7b8d7d7eba9fbe5af0a8bbcdd4c4bb0786dfd4deda0acd19ac6372dea24d0a SHA512 fb19af318a66ba475e04826d9b61163ec85e6ea4503847ec6685940424bac8108cf385546bad1de80fedd1ddbb21054644083dc4908caf7e2e616c6e0673b0e3
+DIST gi-docgen-2023.3.tar.gz 2525675 BLAKE2B eda3ce1e90fb8ce71db34d0040d3df578ea4b2848a2f2e208d0785af2219460217c173a193f60abd1b965c1ee1bab7c7d2797e87026677aa4469968818e39d1f SHA512 de9a94ee30b408cb875f7a7e8015f0f860a65140a4b39b9fc1d5f6ea445ab66b4f7c37786646040b0869a1bf1e7d5f09ae878697428e693a15966c27c5d25fa5
diff --git a/dev-util/gi-docgen/gi-docgen-2023.3.ebuild b/dev-util/gi-docgen/gi-docgen-2023.3.ebuild
new file mode 100644
index 000000000000..54c36ba53d9a
--- /dev/null
+++ b/dev-util/gi-docgen/gi-docgen-2023.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A documentation generator for GObject-based libraries"
+HOMEPAGE="
+ https://gitlab.gnome.org/GNOME/gi-docgen
+ https://pypi.org/project/gi-docgen/
+"
+
+LICENSE="|| ( Apache-2.0 GPL-3+ ) CC0-1.0 OFL-1.1 MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ >=dev-python/markdown-3.2[${PYTHON_USEDEP}]
+ >=dev-python/markupsafe-1[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2[${PYTHON_USEDEP}]
+ >=dev-python/typogrify-2[${PYTHON_USEDEP}]
+ ')
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+
+distutils_enable_tests pytest