summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2025-01-20 21:58:43 +0000
committerSam James <sam@gentoo.org>2025-01-20 21:59:22 +0000
commit1705de92b2bf3806a92acb758f601bb105bebf13 (patch)
tree9cf301e1140c68a11cb586a28d653e71260e0cf8 /dev-util
parentwww-servers/lighttpd: remove unused file (diff)
downloadgentoo-1705de92b2bf3806a92acb758f601bb105bebf13.tar.gz
gentoo-1705de92b2bf3806a92acb758f601bb105bebf13.tar.bz2
gentoo-1705de92b2bf3806a92acb758f601bb105bebf13.zip
dev-util/colm: fix tests
* Drop single test which fails w/ modern C issues (too hard to try pass -std=gnu89 in there) * Make sure tests run against just-built copy (and therefore also work when colm isn't yet installed) Closes: https://bugs.gentoo.org/941565 Closes: https://bugs.gentoo.org/944324 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/colm/colm-0.14.7-r4.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-util/colm/colm-0.14.7-r4.ebuild b/dev-util/colm/colm-0.14.7-r4.ebuild
index 99c32aa91d80..1a78eacc012f 100644
--- a/dev-util/colm/colm-0.14.7-r4.ebuild
+++ b/dev-util/colm/colm-0.14.7-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -47,6 +47,9 @@ src_prepare() {
sed -i -e 's/libcolm\.so/libcolm.dylib/' src/main.cc || die
fi
+ # Test fails w/ modern C (bug #944324)
+ rm test/colm.d/ext1.lm || die
+
eautoreconf
}
@@ -69,7 +72,8 @@ src_test() {
# Build tests
default
- # Run them
+ # Run them (and make sure we use just-built libraries, bug #941565)
+ local -x LD_LIBRARY_PATH="${S}/src/.libs:${S}/src:${LD_LIBRARY_PATH}"
cd test || die
./runtests || die
}