summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-04-13 02:09:55 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-04-13 02:17:09 -0400
commit26190b8f1768367ee46aab16039b30d0b5fd1f25 (patch)
treebc45ee4a9c1f97ab4448a4d0540d69bc9f6effb9 /dev-util
parentapp-arch/7zip: fix #929025, add some comments (diff)
downloadgentoo-26190b8f1768367ee46aab16039b30d0b5fd1f25.tar.gz
gentoo-26190b8f1768367ee46aab16039b30d0b5fd1f25.tar.bz2
gentoo-26190b8f1768367ee46aab16039b30d0b5fd1f25.zip
dev-util/maturin: restrict tests on ppc32 for now
Due to usage of pyo3 crate that's broken on ppc32, can be restored at a later date and not worth trying to manually bump it to fixed pyo3 in the interim. Bug: https://bugs.gentoo.org/927792 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/maturin/maturin-1.5.1-r1.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-util/maturin/maturin-1.5.1-r1.ebuild b/dev-util/maturin/maturin-1.5.1-r1.ebuild
index a692b2fa20a7..d16a841b817f 100644
--- a/dev-util/maturin/maturin-1.5.1-r1.ebuild
+++ b/dev-util/maturin/maturin-1.5.1-r1.ebuild
@@ -441,6 +441,9 @@ KEYWORDS="amd64 arm arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc x86"
IUSE="doc +ssl test"
RESTRICT="!test? ( test )"
+# TODO: cleanup after CRATES_TEST's pyo3 is >=0.20.3 (bug #922236)
+RESTRICT+=" ppc? ( test )"
+
RDEPEND="$(python_gen_cond_dep 'dev-python/tomli[${PYTHON_USEDEP}]' 3.10)"
DEPEND="ssl? ( dev-libs/openssl:= )"
BDEPEND="
@@ -461,6 +464,8 @@ QA_FLAGS_IGNORED="usr/bin/${PN}"
src_prepare() {
distutils-r1_src_prepare
+ [[ ${CRATES_TEST} == *pyo3@0.20.[0-2]* ]] || die "drop ppc test restrict"
+
# we build the Rust executable (just once) via cargo_src_compile
sed -i -e '/setuptools_rust/d' -e '/rust_extensions/d' setup.py || die