summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-02-27 22:02:43 +0000
committerSam James <sam@gentoo.org>2024-02-27 22:03:21 +0000
commit83e9046c59342b7d5c02846b2cafff562b23174d (patch)
treec2add607088c17925892f3c73cd38f3c651f70fd /dev-util
parentdev-util/sh: add 3.8.0 (diff)
downloadgentoo-83e9046c59342b7d5c02846b2cafff562b23174d.tar.gz
gentoo-83e9046c59342b7d5c02846b2cafff562b23174d.tar.bz2
gentoo-83e9046c59342b7d5c02846b2cafff562b23174d.zip
dev-util/sh: always install man pages, drop 9999
I don't see much value in the live ebuild here and it also breaks my go bump script. I could (and should) fix that but I didn't realise we even had a live ebuild for this. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/sh/sh-3.8.0.ebuild34
-rw-r--r--dev-util/sh/sh-9999.ebuild54
2 files changed, 7 insertions, 81 deletions
diff --git a/dev-util/sh/sh-3.8.0.ebuild b/dev-util/sh/sh-3.8.0.ebuild
index 9aa4c37a568f..6aa0a0969770 100644
--- a/dev-util/sh/sh-3.8.0.ebuild
+++ b/dev-util/sh/sh-3.8.0.ebuild
@@ -7,38 +7,20 @@ inherit go-module
DESCRIPTION="A shell parser, formatter, and interpreter with bash support"
HOMEPAGE="https://github.com/mvdan/sh"
-
-if [[ ${PV} == *9999 ]]; then
- EGIT_REPO_URI="https://github.com/mvdan/sh.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/mvdan/sh/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
- SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
- KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
- S="${WORKDIR}/${PN//fmt/}-${PV}"
-fi
+SRC_URI="https://github.com/mvdan/sh/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+S="${WORKDIR}/${PN//fmt/}-${PV}"
LICENSE="Apache-2.0 BSD"
SLOT="0"
-IUSE="+man"
-
-BDEPEND="man? ( app-text/scdoc )"
-
-src_unpack() {
- default
- if [[ ${PV} == *9999 ]]; then
- git-r3_src_unpack
- go-module_live_vendor
- fi
-}
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+BDEPEND="app-text/scdoc"
src_compile() {
# Not bothering with gosh for now as it's very new
# https://github.com/mvdan/sh#gosh
ego build ./cmd/shfmt
- if use man; then
- scdoc <cmd/shfmt/shfmt.1.scd >shfmt.1 || die "conversation of man page failed"
- fi
+ scdoc <cmd/shfmt/shfmt.1.scd >shfmt.1 || die "conversation of man page failed"
}
src_test() {
@@ -48,7 +30,5 @@ src_test() {
src_install() {
dobin shfmt
- if use man; then
- doman shfmt.1
- fi
+ doman shfmt.1
}
diff --git a/dev-util/sh/sh-9999.ebuild b/dev-util/sh/sh-9999.ebuild
deleted file mode 100644
index c85de409caf7..000000000000
--- a/dev-util/sh/sh-9999.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit go-module
-
-DESCRIPTION="A shell parser, formatter, and interpreter with bash support"
-HOMEPAGE="https://github.com/mvdan/sh"
-
-if [[ ${PV} == *9999 ]]; then
- EGIT_REPO_URI="https://github.com/mvdan/sh.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/mvdan/sh/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
- SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
- KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
- S="${WORKDIR}/${PN//fmt/}-${PV}"
-fi
-
-LICENSE="Apache-2.0 BSD"
-SLOT="0"
-IUSE="+man"
-
-BDEPEND="man? ( app-text/scdoc )"
-
-src_unpack() {
- default
- if [[ ${PV} == *9999 ]]; then
- git-r3_src_unpack
- go-module_live_vendor
- fi
-}
-
-src_compile() {
- # Not bothering with gosh for now as it's very new
- # https://github.com/mvdan/sh#gosh
- ego build ./cmd/shfmt
- if use man; then
- scdoc <cmd/shfmt/shfmt.1.scd >shfmt.1 || die "conversation of man page failed"
- fi
-}
-
-src_test() {
- cd syntax || die
- ego test -run=-
-}
-
-src_install() {
- dobin shfmt
- if use man; then
- doman shfmt.1
- fi
-}