summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-11-25 15:19:29 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2018-11-25 15:19:29 +0000
commit9463f900268f70e5094206801bf218cc617cbb60 (patch)
tree8bc1eb947dde103522bbf20c5cf44d02756efd10 /dev-util
parenttoolchain.eclass: drop prepstrip(), bug #587316 (diff)
downloadgentoo-9463f900268f70e5094206801bf218cc617cbb60.tar.gz
gentoo-9463f900268f70e5094206801bf218cc617cbb60.tar.bz2
gentoo-9463f900268f70e5094206801bf218cc617cbb60.zip
dev-util/mingw-runtime: drop prepstrip(), bug #587300
This disables all stripping in mingw-runtime. As PMS does not provide an alternative just drop stripping for now. Reported-by: Michał Górny Closes: https://bugs.gentoo.org/587300 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/mingw-runtime/mingw-runtime-3.18.ebuild3
-rw-r--r--dev-util/mingw-runtime/mingw-runtime-3.20.2.ebuild3
-rw-r--r--dev-util/mingw-runtime/mingw-runtime-3.20.ebuild3
-rw-r--r--dev-util/mingw-runtime/mingw-runtime-4.0.3.1.ebuild3
4 files changed, 4 insertions, 8 deletions
diff --git a/dev-util/mingw-runtime/mingw-runtime-3.18.ebuild b/dev-util/mingw-runtime/mingw-runtime-3.18.ebuild
index fde71e0d98cb..74ba9950cae3 100644
--- a/dev-util/mingw-runtime/mingw-runtime-3.18.ebuild
+++ b/dev-util/mingw-runtime/mingw-runtime-3.18.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=0
@@ -69,7 +69,6 @@ src_install() {
&& insdir="${D}/usr/${CTARGET}" \
|| insdir="${D}"
emake install DESTDIR="${insdir}" || die
- env -uRESTRICT CHOST=${CTARGET} prepallstrip
rm -rf "${insdir}"/usr/doc
dodoc CONTRIBUTORS ChangeLog README TODO readme.txt
fi
diff --git a/dev-util/mingw-runtime/mingw-runtime-3.20.2.ebuild b/dev-util/mingw-runtime/mingw-runtime-3.20.2.ebuild
index cd21a8f2e9f8..f1842bc41165 100644
--- a/dev-util/mingw-runtime/mingw-runtime-3.20.2.ebuild
+++ b/dev-util/mingw-runtime/mingw-runtime-3.20.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="4"
@@ -69,7 +69,6 @@ src_install() {
&& insdir="${D}/usr/${CTARGET}" \
|| insdir="${D}"
emake install DESTDIR="${insdir}" || die
- env -uRESTRICT CHOST=${CTARGET} prepallstrip
rm -rf "${insdir}"/usr/doc
docinto ${CTARGET} # Avoid collisions with other cross-compilers.
dodoc CONTRIBUTORS ChangeLog README TODO readme.txt
diff --git a/dev-util/mingw-runtime/mingw-runtime-3.20.ebuild b/dev-util/mingw-runtime/mingw-runtime-3.20.ebuild
index e75340a8d33d..ed32fcb768c7 100644
--- a/dev-util/mingw-runtime/mingw-runtime-3.20.ebuild
+++ b/dev-util/mingw-runtime/mingw-runtime-3.20.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="4"
@@ -67,7 +67,6 @@ src_install() {
&& insdir="${D}/usr/${CTARGET}" \
|| insdir="${D}"
emake install DESTDIR="${insdir}" || die
- env -uRESTRICT CHOST=${CTARGET} prepallstrip
rm -rf "${insdir}"/usr/doc
docinto ${CTARGET} # Avoid collisions with other cross-compilers.
dodoc CONTRIBUTORS ChangeLog README TODO readme.txt
diff --git a/dev-util/mingw-runtime/mingw-runtime-4.0.3.1.ebuild b/dev-util/mingw-runtime/mingw-runtime-4.0.3.1.ebuild
index 0a13e7773d86..82167469e438 100644
--- a/dev-util/mingw-runtime/mingw-runtime-4.0.3.1.ebuild
+++ b/dev-util/mingw-runtime/mingw-runtime-4.0.3.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="4"
@@ -75,7 +75,6 @@ src_install() {
&& insdir="${D}/usr/${CTARGET}" \
|| insdir="${D}"
emake -j1 install DESTDIR="${insdir}"
- env -uRESTRICT CHOST=${CTARGET} prepallstrip
rm -rf "${insdir}"/usr/doc
docinto ${CTARGET} # Avoid collisions with other cross-compilers.
fi