summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2019-04-11 12:35:54 +0800
committerYixun Lan <dlan@gentoo.org>2019-04-11 12:36:53 +0800
commitd3fe96695eb73271fe2a092fbc2ebda03f94c9f6 (patch)
tree75b16da68d8da29628d22f335f642bcd211e3f49 /dev-util
parentdev-util/repo: add myself to maintainer list (diff)
downloadgentoo-d3fe96695eb73271fe2a092fbc2ebda03f94c9f6.tar.gz
gentoo-d3fe96695eb73271fe2a092fbc2ebda03f94c9f6.tar.bz2
gentoo-d3fe96695eb73271fe2a092fbc2ebda03f94c9f6.zip
dev-util/repo: version bump 1.13.2
which is the lastest stable version Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/repo/Manifest1
-rw-r--r--dev-util/repo/repo-1.13.2.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/repo/Manifest b/dev-util/repo/Manifest
index 9920652fd048..1eb0d2e86603 100644
--- a/dev-util/repo/Manifest
+++ b/dev-util/repo/Manifest
@@ -1 +1,2 @@
DIST repo-1.12.37.tar.gz 115098 BLAKE2B 7a54afad5a3355edfab09be62c6881b4c0d3bc521c04313bb1dd428fc7a1c9a82a65186d20fd05d67227c88d2f6a30fd70f53f35dbfc0b6e7e668252ce6fbd9d SHA512 3ff6b5c3bcc8fba1861102035b86b59137e7dcebeab7a0fb01672da28473e1912c3cbac7c085e9b8d3fce404bd18095ba022d4978d83833f666bd31d621d5953
+DIST repo-1.13.2.tar.xz 103068 BLAKE2B 055ca4ffb55aa304a466e32e84e4ed23781f5be4dc82ce854a0f2352e4b785bec55a3ea23cacd06f758ace4b5351c33cd3e32ecfa0fbb04eb5f4b45349ff7196 SHA512 acd02ded7d817c718e29e1c61dcd83b4e40380de8d3450f5b30aef47f9c1ea4872f04e83299e57999318d43a26d407bf73159394d82700a4a2b30611e5f2e2c1
diff --git a/dev-util/repo/repo-1.13.2.ebuild b/dev-util/repo/repo-1.13.2.ebuild
new file mode 100644
index 000000000000..1123c98edd31
--- /dev/null
+++ b/dev-util/repo/repo-1.13.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# 3.x is currently very buggy, only 2.7 actually works
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1
+
+DESCRIPTION="Google tool for managing git, particularly multiple repos"
+HOMEPAGE="https://android.googlesource.com/tools/repo"
+# Should be:
+#SRC_URI="https://android.googlesource.com/tools/repo/+archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://dev.gentoo.org/~dlan/distfiles/repo-${PV}.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ !app-admin/radmind"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ python_foreach_impl python_fix_shebang ./repo
+ python_foreach_impl python_doexe ./repo
+}