summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-15 05:52:43 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-15 05:52:43 +0100
commite410d59b4f6f21aa39817cdd518cd2e9f7e2d280 (patch)
treed287cde46fb9e27a171c080c8ea3e15b3d2b9f02 /dev-util
parentdev-python/zipp: Bump to 3.18.1 (diff)
downloadgentoo-e410d59b4f6f21aa39817cdd518cd2e9f7e2d280.tar.gz
gentoo-e410d59b4f6f21aa39817cdd518cd2e9f7e2d280.tar.bz2
gentoo-e410d59b4f6f21aa39817cdd518cd2e9f7e2d280.zip
dev-util/stripe-mock: Bump to 0.183.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/stripe-mock/Manifest1
-rw-r--r--dev-util/stripe-mock/stripe-mock-0.183.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/stripe-mock/Manifest b/dev-util/stripe-mock/Manifest
index e31f624304ed..52274ba7b5f1 100644
--- a/dev-util/stripe-mock/Manifest
+++ b/dev-util/stripe-mock/Manifest
@@ -1 +1,2 @@
DIST stripe-mock-0.182.0.tar.gz 1531682 BLAKE2B 35a2b81646cd3bcd57b9b45b12bfa19f16be8337ac3261e163fd68daf33b2fce2eb6b655bf17b7858ef6d63296c404dae7798195ec957b7f73752365688b1f0e SHA512 cdfab6c73554e978bec77047eaff74af9d3a3e48f79b7118c8f9603275adcf825076e70fcf84c49bd561de0748c496df5ff4a2cf4d366e39ab82d7c734f8c456
+DIST stripe-mock-0.183.0.tar.gz 1552131 BLAKE2B e67aa487d375c8d7df36cd53ce2052a8a288512870f96abd45d9206b7572f405f91f94c51c8a1f3f6ca5b5411464741ac1db87f09c6eef721fd86308825ee61b SHA512 5ddc6459752092ecca2691da6bbc13a676b1909f0080be18b4154e3ab9f106cea4e97d3816cda0c237bae560631004ddac92debbf1294d3de262325806c4b21a
diff --git a/dev-util/stripe-mock/stripe-mock-0.183.0.ebuild b/dev-util/stripe-mock/stripe-mock-0.183.0.ebuild
new file mode 100644
index 000000000000..352d14e2ce00
--- /dev/null
+++ b/dev-util/stripe-mock/stripe-mock-0.183.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Mock HTTP server that responds like the real Stripe API"
+HOMEPAGE="https://github.com/stripe/stripe-mock/"
+SRC_URI="https://github.com/stripe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT ISC BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+src_compile() {
+ emake build
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ dobin stripe-mock
+ einstalldocs
+}