summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2019-01-08 09:28:32 +0100
committerFabian Groffen <grobian@gentoo.org>2019-01-08 09:28:32 +0100
commita6b4a73378a8051adb9bc3a7da7d62412f573139 (patch)
tree92ae8f6c2405f76c437d029c53ba2a24ad95bba2 /dev-vcs/hg-git/hg-git-0.8.12-r1.ebuild
parentsys-apps/fwupd: Removed old. (diff)
downloadgentoo-a6b4a73378a8051adb9bc3a7da7d62412f573139.tar.gz
gentoo-a6b4a73378a8051adb9bc3a7da7d62412f573139.tar.bz2
gentoo-a6b4a73378a8051adb9bc3a7da7d62412f573139.zip
dev-vcs/hg-git: revbump for hg-4.8 support
Signed-off-by: Fabian Groffen <grobian@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-vcs/hg-git/hg-git-0.8.12-r1.ebuild')
-rw-r--r--dev-vcs/hg-git/hg-git-0.8.12-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-vcs/hg-git/hg-git-0.8.12-r1.ebuild b/dev-vcs/hg-git/hg-git-0.8.12-r1.ebuild
new file mode 100644
index 000000000000..e5711f08ff40
--- /dev/null
+++ b/dev-vcs/hg-git/hg-git-0.8.12-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="push to and pull from a Git repository using Mercurial"
+HOMEPAGE="http://hg-git.github.io https://pypi.org/project/hg-git/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="
+ >=dev-vcs/mercurial-2.8.2[${PYTHON_USEDEP}]
+ >=dev-python/dulwich-0.9.7[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-hg-4.8.patch
+)