summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <dirkjan@ochtman.nl>2016-05-13 11:41:58 +0200
committerDirkjan Ochtman <dirkjan@ochtman.nl>2016-05-13 11:41:58 +0200
commit134ce903d37ef5edddda6cf494fdd3020a338d08 (patch)
treeb921be4a465751178f777a4b2714054935c121f5 /dev-vcs/hgsubversion/hgsubversion-1.8.6.ebuild
parentapp-admin/ansible: amd64 stable wrt bug #580126 (diff)
downloadgentoo-134ce903d37ef5edddda6cf494fdd3020a338d08.tar.gz
gentoo-134ce903d37ef5edddda6cf494fdd3020a338d08.tar.bz2
gentoo-134ce903d37ef5edddda6cf494fdd3020a338d08.zip
dev-vcs/hgsubversion: version bump to 1.8.6
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-vcs/hgsubversion/hgsubversion-1.8.6.ebuild')
-rw-r--r--dev-vcs/hgsubversion/hgsubversion-1.8.6.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-vcs/hgsubversion/hgsubversion-1.8.6.ebuild b/dev-vcs/hgsubversion/hgsubversion-1.8.6.ebuild
new file mode 100644
index 000000000000..4b4ce127570a
--- /dev/null
+++ b/dev-vcs/hgsubversion/hgsubversion-1.8.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="hgsubversion is a Mercurial extension for working with Subversion repositories"
+HOMEPAGE="https://bitbucket.org/durin42/hgsubversion/wiki/Home https://pypi.python.org/pypi/hgsubversion"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="test"
+
+# although any ref absent in the source, tests fail badly with >=mercurial-2.8.1
+RDEPEND=">=dev-vcs/mercurial-1.4[${PYTHON_USEDEP}]
+ dev-vcs/mercurial[${PYTHON_USEDEP}]
+ || (
+ >=dev-python/subvertpy-0.7.4[${PYTHON_USEDEP}]
+ >=dev-vcs/subversion-1.5[python] )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+DOCS=( README )
+
+#python_test() {
+# "${PYTHON}" tests/run.py || die "Tests failed under ${EPYTHON}"
+#}