summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2024-06-02 16:33:58 -0500
committerWilliam Hubbs <williamh@gentoo.org>2024-06-02 16:34:14 -0500
commit8630ff7219b315f4a48bb3db9917f95aa5518294 (patch)
tree0148d35ff691bfa2b8d050ab473f7dfd98de23e5 /dev-vcs/python-gitlab
parentgnome-extra/cinnamon: Stabilize 6.0.4 amd64, #932975 (diff)
downloadgentoo-8630ff7219b315f4a48bb3db9917f95aa5518294.tar.gz
gentoo-8630ff7219b315f4a48bb3db9917f95aa5518294.tar.bz2
gentoo-8630ff7219b315f4a48bb3db9917f95aa5518294.zip
dev-vcs/python-gitlab: add 4.6.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-vcs/python-gitlab')
-rw-r--r--dev-vcs/python-gitlab/Manifest1
-rw-r--r--dev-vcs/python-gitlab/python-gitlab-4.6.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-vcs/python-gitlab/Manifest b/dev-vcs/python-gitlab/Manifest
index 807abe47be74..86fe4c694f1f 100644
--- a/dev-vcs/python-gitlab/Manifest
+++ b/dev-vcs/python-gitlab/Manifest
@@ -1 +1,2 @@
DIST python-gitlab-3.13.0.tar.gz 270646 BLAKE2B ff7e3c35525ac1bf1cb6dc6e668ca9c8aeefb12073636f115c8e078aa4b9f623f6d847d8487e85e9a325b6f0ad1ef93826631cb32fd86c0bd9023688aac5add9 SHA512 373347392d7030c817a8dcb4cceea71d0609f9e09dce348514c1ca024307094b1a72e287c871ce5fcba9b9d4cdfcc7dc6b4495e2b225b845a3dff2e2dfc4fe82
+DIST python-gitlab-4.6.0.tar.gz 470253 BLAKE2B 25859017478c9c1896088bd706da1980f5c90dff075fa8a9373933852e1a83daf543f7a48acce4619da7077cdfaf64b0cc9f868cd99ee4d8868294f3328d0d13 SHA512 1d0178dd4d0456b25d5d6ecbcb39137cbc273bf4ac1863b696d39fcdb50c927b606b18ea3b21ce66e92102979584bc3922e65577e0d0c72ae937e984ec21cbc3
diff --git a/dev-vcs/python-gitlab/python-gitlab-4.6.0.ebuild b/dev-vcs/python-gitlab/python-gitlab-4.6.0.ebuild
new file mode 100644
index 000000000000..4da36920b512
--- /dev/null
+++ b/dev-vcs/python-gitlab/python-gitlab-4.6.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+MY_PN="${PN/-/_}"
+PYTHON_COMPAT=( python3_{9..12} )
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+inherit distutils-r1
+
+DESCRIPTION="Python command line interface to gitlab API"
+HOMEPAGE="https://github.com/python-gitlab/python-gitlab/"
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/python-gitlab/python-gitlab"
+ inherit git-r3
+else
+ inherit pypi
+ SRC_URI="$(pypi_sdist_url) -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+LICENSE="LGPL-3"
+SLOT="0"
+
+BDEPEND="test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ >=dev-python/pytest-console-scripts-1.3.1[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.2[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )"
+
+RDEPEND=">=dev-python/requests-2.32.2[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-1.0.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc -r *.rst docs
+}