summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2017-08-27 22:39:19 +0200
committerSebastian Pipping <sping@gentoo.org>2017-08-27 22:55:34 +0200
commit1574d2d030eecc9a8c37a5099ec2b92fbeae9e4e (patch)
tree0e5858be1944fabdb98df6dbad22c300080fad69 /dev-vcs/svn2git/svn2git-9999.ebuild
parentsys-fs/unionfs-fuse: 2.0 (diff)
downloadgentoo-1574d2d030eecc9a8c37a5099ec2b92fbeae9e4e.tar.gz
gentoo-1574d2d030eecc9a8c37a5099ec2b92fbeae9e4e.tar.bz2
gentoo-1574d2d030eecc9a8c37a5099ec2b92fbeae9e4e.zip
dev-vcs/svn2git: 1.0.11
Also bump to EAPI 5 (not 6), and sync live ebuild Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-vcs/svn2git/svn2git-9999.ebuild')
-rw-r--r--dev-vcs/svn2git/svn2git-9999.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/dev-vcs/svn2git/svn2git-9999.ebuild b/dev-vcs/svn2git/svn2git-9999.ebuild
index eb455c658b14..c9fa2d784940 100644
--- a/dev-vcs/svn2git/svn2git-9999.ebuild
+++ b/dev-vcs/svn2git/svn2git-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="2"
+EAPI="5"
inherit eutils qt4-r2
-[ "$PV" == "9999" ] && inherit git-2
+[ "$PV" == "9999" ] && inherit git-r3
DESCRIPTION="Tool for one-time conversion from svn to git"
HOMEPAGE="https://github.com/svn-all-fast-export/svn2git"
@@ -12,7 +12,7 @@ if [ "$PV" == "9999" ]; then
EGIT_REPO_URI="https://github.com/svn-all-fast-export/svn2git.git"
KEYWORDS=""
else
- SRC_URI="https://www.hartwork.org/public/${P}.tar.gz"
+ SRC_URI="https://github.com/svn-all-fast-export/svn2git/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
@@ -26,19 +26,19 @@ DEPEND="dev-vcs/subversion
RDEPEND="${DEPEND}
dev-vcs/git"
-S=${WORKDIR}/${PN}-${PN}
-
src_prepare() {
# Note: patching order matters
epatch "${FILESDIR}"/${PN}-1.0.2.1-include-path.patch
if [[ "$PV" != "9999" ]]; then
- epatch "${FILESDIR}"/${P}-version.patch
+ epatch "${FILESDIR}"/${PN}-1.0.10-version.patch
+ export SVN_ALL_FAST_EXPORT_VERSION=${PVR} # for src_compile
fi
qt4-r2_src_prepare
}
src_install() {
+ dodoc README.md
insinto /usr/share/${PN}/samples
doins samples/*.rules || die 'doins failed'
dobin svn-all-fast-export || die 'dobin failed'