summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-03-25 21:48:29 +0000
committerMarek Szuba <marecki@gentoo.org>2023-03-25 21:48:29 +0000
commit099bd297f531f478fcc4a9b2cf0da90d739fafe1 (patch)
treed7170e1c81a8e457cb368c20ba49f3a73fe9f44c /dev-vcs
parentapp-admin/ansible-lint: add 6.14.3 (diff)
downloadgentoo-099bd297f531f478fcc4a9b2cf0da90d739fafe1.tar.gz
gentoo-099bd297f531f478fcc4a9b2cf0da90d739fafe1.tar.bz2
gentoo-099bd297f531f478fcc4a9b2cf0da90d739fafe1.zip
dev-vcs/pre-commit: add 3.2.1, drop 3.1.1
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/pre-commit/Manifest2
-rw-r--r--dev-vcs/pre-commit/pre-commit-3.2.1.ebuild (renamed from dev-vcs/pre-commit/pre-commit-3.1.1.ebuild)3
2 files changed, 3 insertions, 2 deletions
diff --git a/dev-vcs/pre-commit/Manifest b/dev-vcs/pre-commit/Manifest
index 41fb1507e477..36eb088f6b44 100644
--- a/dev-vcs/pre-commit/Manifest
+++ b/dev-vcs/pre-commit/Manifest
@@ -1,3 +1,3 @@
DIST pre-commit-2.20.0.gh.tar.gz 266604 BLAKE2B 470f032e6d5bfcdd9ac8ba8f37d4323b601da0c82bcd524ffc575dc688fe81ad326a1f6a8ddd03da6e37130319ee40070c03d9789cd6e0e4b427a1d6e646416e SHA512 b1da558a0e5d8f2f655427089f1d0b11b01ad7513ece7a0b3b67c33529cf3584edba558c78704e6da6ca18876b1d6c0fa8698e01fd7c2439b8d4dc0a93961e52
DIST pre-commit-3.0.4.gh.tar.gz 264952 BLAKE2B 3c45da675d5a1a1fc115db0ef7186c1ec1e5a6d6d9353c5a53dba85a14de2c94bafe0ef9e8d0b04bae55ded81890d726997e695c95889719096205e1b212a237 SHA512 d51aca29b50f67ae42aa70d849939e6af96ff64c6fb214cddbc5a35cacebb8a54a4911110d0615a1a499516fcc2a06bb47d7e11da84ef636c3fcfdc8d2cbe343
-DIST pre-commit-3.1.1.gh.tar.gz 265999 BLAKE2B eff0708397ae88d0223b65168d1dca4e2a6ced808a504d28c10ab6c626682475ef0c5c165dbd13975fb29cdc869abc018d2c1b3a596f904e14357bb3598f1a96 SHA512 e707b9c28f75ae61a9c08dc7031e22c048c8757b4ae6c8fa18c712ab8c5a6d891f62d7b0c8962456931b7281d3a55bfce55569bf44bf65e03661596ed367120c
+DIST pre-commit-3.2.1.gh.tar.gz 267233 BLAKE2B 39843fa9f7529ee38670b3c7ebea1e29b080db47ae3db73d5a218455fd51b7bf86bb1ab1a979946a57bf6417f8a4e7050e8ba34f873bf4d76fa49fa76358964e SHA512 5e2c114049d84eae2ec6cbf123c8e3976d8e9e392a6e04f78d446ad85758a78fb912c0f6070b9c506f8c1bb87e1fd1ecbe763deb8d1430e1d3d8f296dd0cc389
diff --git a/dev-vcs/pre-commit/pre-commit-3.1.1.ebuild b/dev-vcs/pre-commit/pre-commit-3.2.1.ebuild
index 7207920c1aee..5f06fdcab423 100644
--- a/dev-vcs/pre-commit/pre-commit-3.1.1.ebuild
+++ b/dev-vcs/pre-commit/pre-commit-3.2.1.ebuild
@@ -45,11 +45,12 @@ DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
# and while some of them do include "skip if not found" logic, most of them do not.
# The latter consistently fail with
# Calling "git rev-parse" fails with "fatal: not a git repository (or any of the parent directories): .git".
-# including with the sandbox disabled and when run manually with tox.
+# including with the sandbox disabled.
EPYTEST_DESELECT=(
tests/languages/
tests/repository_test.py
tests/main_test.py::test_all_cmds
+ tests/main_test.py::test_hook_stage_migration
tests/main_test.py::test_try_repo
)