summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-11-10 00:09:17 +0000
committerMarek Szuba <marecki@gentoo.org>2022-11-10 00:42:12 +0000
commit8bf80257ef40aab4a85f2270648557e331097c88 (patch)
treed19c560cfb2d31e8760fd6129503407b62129d0d /dev-vcs
parentapp-admin/ansible-lint: drop 6.5.2, 6.7.0 (diff)
downloadgentoo-8bf80257ef40aab4a85f2270648557e331097c88.tar.gz
gentoo-8bf80257ef40aab4a85f2270648557e331097c88.tar.bz2
gentoo-8bf80257ef40aab4a85f2270648557e331097c88.zip
dev-vcs/git-machete: add 3.13.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-machete/Manifest1
-rw-r--r--dev-vcs/git-machete/git-machete-3.13.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-vcs/git-machete/Manifest b/dev-vcs/git-machete/Manifest
index 79dc98e32e30..ffaee9af11d7 100644
--- a/dev-vcs/git-machete/Manifest
+++ b/dev-vcs/git-machete/Manifest
@@ -1,2 +1,3 @@
DIST git-machete-3.12.4.gh.tar.gz 1381813 BLAKE2B 2eb0f8d72fe82cd68bf8f778979ed8a14c2cfd9e752f02f3c0c69e53000c5f8877c433fdaa461f988545e60687d5516c28ee7de0eb2bfd1bc377fcc129425c6b SHA512 39217be678d1cc2fa52a314ebeabf127e71ae130dcbdc8a93bdd075e3130ca2ce2464e153367f8eccc61315234cfe39ec675920eca4599dca41167abc195c1d4
DIST git-machete-3.12.5.gh.tar.gz 1386934 BLAKE2B f6a1966fc37dfc6b726f453751d97b466720db6e574bf76e3b830f0895a1f98dd73cbe367c2c4bd20662f434f1e19809324d3a695f5cf62471db38c47648e34f SHA512 8ed7dc13fbcd965e9867b882a2d80cf514b5d8de653a0e19f26fef808e51a53f2fcf9ca0971d1c6b40161d397341af8f4e823175452294b603b1f6559144c715
+DIST git-machete-3.13.0.gh.tar.gz 1388145 BLAKE2B e12c12ff5a34b7dee0ea14f4260154dc5c94a356a584c3bd00688777b4425a4c45fd39ece0c76751ff8b9b45c131ccd3d4ea25c3f14711ac91f75fa6a47e651e SHA512 85d719e9a983db9aea7bb7540c85aeb6ac5bfcbf94e4920683b37bae22714078f5e8b9a39d63fa397a03ddf139c52acd970310e499a26296fbdb1091672873f9
diff --git a/dev-vcs/git-machete/git-machete-3.13.0.ebuild b/dev-vcs/git-machete/git-machete-3.13.0.ebuild
new file mode 100644
index 000000000000..9c6b4673cedb
--- /dev/null
+++ b/dev-vcs/git-machete/git-machete-3.13.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Probably the sharpest git repo organizer & rebase/merge workflow automation tool"
+HOMEPAGE="https://github.com/VirtusLab/git-machete https://pypi.org/project/git-machete/"
+# No tests in PyPI tarballs
+SRC_URI="https://github.com/VirtusLab/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="dev-vcs/git"
+BDEPEND="test? (
+ >=dev-python/pytest-mock-3.8.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-2.5.0[${PYTHON_USEDEP}]
+)"
+
+DOCS=( CONTRIBUTING.md README.md )
+
+distutils_enable_sphinx docs/source dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+
+ newbashcomp completion/${PN}.completion.bash ${PN}
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins completion/${PN}.fish
+
+ insinto /usr/share/zsh/site-functions
+ newins completion/${PN}.completion.zsh _${PN}
+}