summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/minetest
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/minetest')
-rw-r--r--games-action/minetest/Manifest1
-rw-r--r--games-action/minetest/files/minetest-0.4.10-as-needed.patch35
-rw-r--r--games-action/minetest/files/minetest-0.4.10-shared-irrlicht.patch23
-rw-r--r--games-action/minetest/files/minetest-0.4.10-system-lua.patch37
-rw-r--r--games-action/minetest/files/minetestserver.confd16
-rw-r--r--games-action/minetest/files/minetestserver.initd36
-rw-r--r--games-action/minetest/metadata.xml55
-rw-r--r--games-action/minetest/minetest-0.4.10-r1.ebuild150
-rw-r--r--games-action/minetest/minetest-0.4.10-r2.ebuild147
9 files changed, 500 insertions, 0 deletions
diff --git a/games-action/minetest/Manifest b/games-action/minetest/Manifest
new file mode 100644
index 000000000000..e05f300fa627
--- /dev/null
+++ b/games-action/minetest/Manifest
@@ -0,0 +1 @@
+DIST minetest-0.4.10.tar.gz 5291236 SHA256 05d15c8e2c8e53ee9d3006e79c2b59200311a7b879220d8b6f6a6fd2acf806b6 SHA512 0d2f2590df530df9bed11a08a3e67dfa39dae1987b8c1f6a4f4f2ace2c40dea3b5afce445e3b2e17b2bd8a426bdd53d717989018f5da531b1eb10965d953c3bf WHIRLPOOL 016c2bc6f9aed44943f238491c445f48013f76a74f9c09e56c1e70e03fa3ded72b042b9dffa0bed81a9dcdc84358a9be88bbf32119dd45a1e2a9873031be1009
diff --git a/games-action/minetest/files/minetest-0.4.10-as-needed.patch b/games-action/minetest/files/minetest-0.4.10-as-needed.patch
new file mode 100644
index 000000000000..83d1ca7b0b9e
--- /dev/null
+++ b/games-action/minetest/files/minetest-0.4.10-as-needed.patch
@@ -0,0 +1,35 @@
+commit a88bfd5b77fa0b5c60e438c0011dbdcee5e14dfd
+Author: hasufell <hasufell@gentoo.org>
+Date: Mon Nov 25 00:28:55 2013 +0100
+
+ CMAKE: fix linking order
+
+ this also fixes linking with as-needed wrt
+ https://github.com/minetest/minetest/issues/617
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index a1fee7a..a72bd4a 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -427,18 +427,18 @@ if(BUILD_CLIENT)
+ set(minetest_LIBS
+ ${PROJECT_NAME}
+ ${ZLIB_LIBRARIES}
+- ${IRRLICHT_LIBRARY}
++ ${X11_LIBRARIES}
+ ${OPENGL_LIBRARIES}
++ ${OPENGLES2_LIBRARIES}
+ ${JPEG_LIBRARIES}
+ ${BZIP2_LIBRARIES}
+ ${PNG_LIBRARIES}
+- ${X11_LIBRARIES}
++ ${IRRLICHT_LIBRARY}
+ ${GETTEXT_LIBRARY}
+ ${SOUND_LIBRARIES}
+ ${SQLITE3_LIBRARY}
+ ${LUA_LIBRARY}
+ ${JSON_LIBRARY}
+- ${OPENGLES2_LIBRARIES}
+ ${PLATFORM_LIBS}
+ ${CLIENT_PLATFORM_LIBS}
+ )
diff --git a/games-action/minetest/files/minetest-0.4.10-shared-irrlicht.patch b/games-action/minetest/files/minetest-0.4.10-shared-irrlicht.patch
new file mode 100644
index 000000000000..b552c0937039
--- /dev/null
+++ b/games-action/minetest/files/minetest-0.4.10-shared-irrlicht.patch
@@ -0,0 +1,23 @@
+commit 11d35e62fe13b47c5b34139559e650dfe6ebbd84
+Author: hasufell <julian.ospald@googlemail.com>
+Date: Sat Jun 8 13:40:30 2013 +0200
+
+ CMAKE: use shared lib from Irrlicht
+
+diff --git a/cmake/Modules/FindIrrlicht.cmake b/cmake/Modules/FindIrrlicht.cmake
+index bd00422..4632993 100644
+--- a/cmake/Modules/FindIrrlicht.cmake
++++ b/cmake/Modules/FindIrrlicht.cmake
+@@ -50,10 +50,11 @@ else()
+ /usr/include/irrlicht
+ )
+
+- FIND_LIBRARY(IRRLICHT_LIBRARY NAMES libIrrlicht.a Irrlicht
++ FIND_LIBRARY(IRRLICHT_LIBRARY NAMES libIrrlicht.so Irrlicht
+ PATHS
+ /usr/local/lib
+ /usr/lib
++ /usr/lib64
+ )
+ endif()
+
diff --git a/games-action/minetest/files/minetest-0.4.10-system-lua.patch b/games-action/minetest/files/minetest-0.4.10-system-lua.patch
new file mode 100644
index 000000000000..c31c8514ea29
--- /dev/null
+++ b/games-action/minetest/files/minetest-0.4.10-system-lua.patch
@@ -0,0 +1,37 @@
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -215,8 +215,6 @@
+ message (STATUS "LuaJIT headers: ${LUA_INCLUDE_DIR}")
+ else (NOT ${DISABLE_LUAJIT} MATCHES "1")
+ message (STATUS "LuaJIT detection disabled! (DISABLE_LUAJIT=1)")
+- set(LUA_LIBRARY "")
+- set(LUA_INCLUDE_DIR "")
+ endif (NOT DISABLE_LUAJIT)
+
+ set(USE_LUAJIT 0)
+@@ -267,11 +265,22 @@
+ endif (VALID_LUAJIT_VERSION)
+ endif (LUA_LIBRARY AND LUA_INCLUDE_DIR)
+
++OPTION(WITH_BUNDLED_LUA "Use bundled lua")
++
+ if(NOT USE_LUAJIT)
+ message (STATUS "LuaJIT not found, using bundled Lua.")
+- set(LUA_INCLUDE_DIR "${PROJECT_SOURCE_DIR}/lua/src")
+- set(LUA_LIBRARY "lua")
+- add_subdirectory(lua)
++ if (WITH_BUNDLED_LUA)
++ set(LUA_INCLUDE_DIR "${PROJECT_SOURCE_DIR}/lua/src")
++ set(LUA_LIBRARY "lua")
++ add_subdirectory(lua)
++ else (WITH_BUNDLED_LUA)
++ find_package(Lua51)
++ if(LUA51_FOUND)
++ message (STATUS "Lua51 found")
++ else(LUA51_FOUND)
++ message (FATAL_ERROR "Lua51 not found!")
++ endif(LUA51_FOUND)
++ endif(WITH_BUNDLED_LUA)
+ endif(NOT USE_LUAJIT)
+
+ mark_as_advanced(LUA_LIBRARY)
diff --git a/games-action/minetest/files/minetestserver.confd b/games-action/minetest/files/minetestserver.confd
new file mode 100644
index 000000000000..ec3d0138cb73
--- /dev/null
+++ b/games-action/minetest/files/minetestserver.confd
@@ -0,0 +1,16 @@
+# /etc/conf.d/minetest-server: config file for /etc/init.d/minetest-server
+
+# user
+USER="minetest"
+
+# group
+GROUP="@GROUP@"
+
+# pidfile
+PIDFILE="/var/run/minetest.pid"
+
+# executable
+MINETESTBIN="@BINDIR@/minetestserver"
+
+# additional arguments for the server
+ARGS="--logfile /var/lib/minetest/minetest-server.log"
diff --git a/games-action/minetest/files/minetestserver.initd b/games-action/minetest/files/minetestserver.initd
new file mode 100644
index 000000000000..88bfba9edd30
--- /dev/null
+++ b/games-action/minetest/files/minetestserver.initd
@@ -0,0 +1,36 @@
+#!/sbin/runscript
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+description="Minetest dedicated server"
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "starting server"
+ start-stop-daemon \
+ --start \
+ --quiet \
+ --make-pidfile \
+ --pidfile "${PIDFILE}" \
+ --background \
+ --user ${USER} \
+ --group ${GROUP} \
+ --exec "${MINETESTBIN}" -- ${ARGS}
+
+ eend $?
+}
+
+stop() {
+ ebegin "stopping server"
+ start-stop-daemon \
+ --stop \
+ --signal 15 \
+ --quiet \
+ --pidfile "${PIDFILE}"
+
+ eend $?
+}
diff --git a/games-action/minetest/metadata.xml b/games-action/minetest/metadata.xml
new file mode 100644
index 000000000000..e8a8611674de
--- /dev/null
+++ b/games-action/minetest/metadata.xml
@@ -0,0 +1,55 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>maddin081591@gmail.com</email>
+ <name>Martin-Kevin Neumann</name>
+ <description>Proxy maintainer, CC him on bugs</description>
+ </maintainer>
+ <longdescription lang="en">
+ Minetest is an infinite-world block sandbox game and a game
+ engine, inspired by InfiniMiner, Minecraft and the like. It has
+ been in development and use since October 2010.
+
+ It is Free and Open Source Software, released under the LGPL 2.1
+ or later, available for Windows, Mac OS X and Linux.
+
+ Minetest is developed by a random bunch of lunatics.
+
+ Minetest is designed to be simple, stable and portable. It is
+ lightweight enough to run on fairly old hardware. It currently
+ runs playably on a laptop with Intel 945GM graphics. Though, as
+ for the CPU, dualcore is recommended.
+
+ Features
+ * Walk around, dig and build in an infinite voxel world,
+ and craft stuff from raw materials to help you along the way.
+ * Simplistic Modding API that supports many kinds of additions
+ and modifications to the game.
+ * Multiplayer support for tens of players, via servers hosted by
+ users.
+ * Voxel based lighting with gameplay consequences
+ (light caves and buildings with torches)
+ * Almost infinite world and a beautiful map generator.
+ * Runs natively on Windows, Linux, OS X and FreeBSD.
+ * Supports multiple languages, translated by the community.
+ </longdescription>
+ <use>
+ <flag name="leveldb">Enable LevelDB backend</flag>
+ <flag name="luajit">
+ Use <pkg>dev-lang/luajit</pkg>
+ instead of <pkg>dev-lang/lua</pkg>
+ </flag>
+ <flag name="redis">Enable redis backend via
+ <pkg>dev-libs/hiredis</pkg>
+ </flag>
+ <flag name="server">Build minetest server</flag>
+ </use>
+ <upstream>
+ <bugs-to>https://github.com/minetest/minetest/issues</bugs-to>
+ <doc lang="en">http://wiki.minetest.net/Main_Page</doc>
+ <remote-id type="github">minetest/minetest</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-action/minetest/minetest-0.4.10-r1.ebuild b/games-action/minetest/minetest-0.4.10-r1.ebuild
new file mode 100644
index 000000000000..4063a7b5762b
--- /dev/null
+++ b/games-action/minetest/minetest-0.4.10-r1.ebuild
@@ -0,0 +1,150 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils cmake-utils gnome2-utils vcs-snapshot user games
+
+DESCRIPTION="An InfiniMiner/Minecraft inspired game"
+HOMEPAGE="http://minetest.net/"
+SRC_URI="http://github.com/minetest/minetest/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="+curl dedicated leveldb luajit nls redis +server +sound +truetype"
+
+RDEPEND="dev-db/sqlite:3
+ sys-libs/zlib
+ curl? ( net-misc/curl )
+ !dedicated? (
+ app-arch/bzip2
+ >=dev-games/irrlicht-1.8-r2
+ media-libs/libpng:0
+ virtual/jpeg
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXxf86vm
+ sound? (
+ media-libs/libogg
+ media-libs/libvorbis
+ media-libs/openal
+ )
+ truetype? ( media-libs/freetype:2 )
+ )
+ leveldb? ( dev-libs/leveldb )
+ luajit? ( dev-lang/luajit:2 )
+ !luajit? ( >=dev-lang/lua-5.1.4[deprecated] )
+ nls? ( virtual/libintl )
+ redis? ( dev-libs/hiredis )"
+DEPEND="${RDEPEND}
+ >=dev-games/irrlicht-1.8-r2
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ games_pkg_setup
+
+ if use server || use dedicated ; then
+ enewuser ${PN} -1 -1 /var/lib/${PN} ${GAMES_GROUP}
+ fi
+}
+
+src_unpack() {
+ vcs-snapshot_src_unpack
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-shared-irrlicht.patch \
+ "${FILESDIR}"/${P}-as-needed.patch \
+ "${FILESDIR}"/${P}-system-lua.patch
+
+ # correct gettext behavior
+ if [[ -n "${LINGUAS+x}" ]] ; then
+ for i in $(cd po ; echo *) ; do
+ if ! has ${i} ${LINGUAS} ; then
+ rm -r po/${i} || die
+ fi
+ done
+ fi
+
+ # jthread is modified
+ # json is modified
+ rm -r src/{lua,sqlite} || die
+
+ # set paths
+ sed \
+ -e "s#@BINDIR@#${GAMES_BINDIR}#g" \
+ -e "s#@GROUP@#${GAMES_GROUP}#g" \
+ "${FILESDIR}"/minetestserver.confd > "${T}"/minetestserver.confd || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(usex dedicated "-DBUILD_SERVER=ON -DBUILD_CLIENT=OFF" "$(cmake-utils_use_build server SERVER) -DBUILD_CLIENT=ON")
+ -DCUSTOM_BINDIR="${GAMES_BINDIR}"
+ -DCUSTOM_DOCDIR="/usr/share/doc/${PF}"
+ -DCUSTOM_LOCALEDIR="/usr/share/locale"
+ -DCUSTOM_SHAREDIR="${GAMES_DATADIR}/${PN}"
+ $(cmake-utils_use_enable curl CURL)
+ $(cmake-utils_use_enable truetype FREETYPE)
+ $(cmake-utils_use_enable nls GETTEXT)
+ -DENABLE_GLES=0
+ $(cmake-utils_use_enable leveldb LEVELDB)
+ $(cmake-utils_use_enable redis REDIS)
+ $(cmake-utils_use_enable sound SOUND)
+ $(cmake-utils_use !luajit DISABLE_LUAJIT)
+ -DRUN_IN_PLACE=0
+ -DWITH_BUNDLED_LUA=0
+ $(use dedicated && {
+ echo "-DIRRLICHT_SOURCE_DIR=/the/irrlicht/source"
+ echo "-DIRRLICHT_INCLUDE_DIR=/usr/include/irrlicht"
+ })
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use server || use dedicated ; then
+ newinitd "${FILESDIR}"/minetestserver.initd minetest-server
+ newconfd "${T}"/minetestserver.confd minetest-server
+ fi
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+
+ if ! use dedicated ; then
+ elog
+ elog "optional dependencies:"
+ elog " games-action/minetest_game (official mod)"
+ elog
+ fi
+
+ if use server || use dedicated ; then
+ elog
+ elog "Configure your server via /etc/conf.d/minetest-server"
+ elog "The user \"minetest\" is created with /var/lib/${PN} homedir."
+ elog "Default logfile is ~/minetest-server.log"
+ elog
+ fi
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-action/minetest/minetest-0.4.10-r2.ebuild b/games-action/minetest/minetest-0.4.10-r2.ebuild
new file mode 100644
index 000000000000..9e15dd4c6eac
--- /dev/null
+++ b/games-action/minetest/minetest-0.4.10-r2.ebuild
@@ -0,0 +1,147 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils cmake-utils gnome2-utils vcs-snapshot user games
+
+DESCRIPTION="An InfiniMiner/Minecraft inspired game"
+HOMEPAGE="http://minetest.net/"
+SRC_URI="http://github.com/minetest/minetest/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+curl dedicated leveldb luajit nls redis +server +sound +truetype"
+
+RDEPEND="dev-db/sqlite:3
+ sys-libs/zlib
+ curl? ( net-misc/curl )
+ !dedicated? (
+ app-arch/bzip2
+ >=dev-games/irrlicht-1.8-r2
+ media-libs/libpng:0
+ virtual/jpeg
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXxf86vm
+ sound? (
+ media-libs/libogg
+ media-libs/libvorbis
+ media-libs/openal
+ )
+ truetype? ( media-libs/freetype:2 )
+ )
+ leveldb? ( dev-libs/leveldb )
+ luajit? ( dev-lang/luajit:2 )
+ nls? ( virtual/libintl )
+ redis? ( dev-libs/hiredis )"
+DEPEND="${RDEPEND}
+ >=dev-games/irrlicht-1.8-r2
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ games_pkg_setup
+
+ if use server || use dedicated ; then
+ enewuser ${PN} -1 -1 /var/lib/${PN} ${GAMES_GROUP}
+ fi
+}
+
+src_unpack() {
+ vcs-snapshot_src_unpack
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-shared-irrlicht.patch \
+ "${FILESDIR}"/${P}-as-needed.patch
+
+ # correct gettext behavior
+ if [[ -n "${LINGUAS+x}" ]] ; then
+ for i in $(cd po ; echo *) ; do
+ if ! has ${i} ${LINGUAS} ; then
+ rm -r po/${i} || die
+ fi
+ done
+ fi
+
+ # jthread is modified
+ # json is modified
+ rm -r src/sqlite || die
+
+ # set paths
+ sed \
+ -e "s#@BINDIR@#${GAMES_BINDIR}#g" \
+ -e "s#@GROUP@#${GAMES_GROUP}#g" \
+ "${FILESDIR}"/minetestserver.confd > "${T}"/minetestserver.confd || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(usex dedicated "-DBUILD_SERVER=ON -DBUILD_CLIENT=OFF" "$(cmake-utils_use_build server SERVER) -DBUILD_CLIENT=ON")
+ -DCUSTOM_BINDIR="${GAMES_BINDIR}"
+ -DCUSTOM_DOCDIR="/usr/share/doc/${PF}"
+ -DCUSTOM_LOCALEDIR="/usr/share/locale"
+ -DCUSTOM_SHAREDIR="${GAMES_DATADIR}/${PN}"
+ $(cmake-utils_use_enable curl CURL)
+ $(cmake-utils_use_enable truetype FREETYPE)
+ $(cmake-utils_use_enable nls GETTEXT)
+ -DENABLE_GLES=0
+ $(cmake-utils_use_enable leveldb LEVELDB)
+ $(cmake-utils_use_enable redis REDIS)
+ $(cmake-utils_use_enable sound SOUND)
+ $(cmake-utils_use !luajit DISABLE_LUAJIT)
+ -DRUN_IN_PLACE=0
+ $(use dedicated && {
+ echo "-DIRRLICHT_SOURCE_DIR=/the/irrlicht/source"
+ echo "-DIRRLICHT_INCLUDE_DIR=/usr/include/irrlicht"
+ })
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use server || use dedicated ; then
+ newinitd "${FILESDIR}"/minetestserver.initd minetest-server
+ newconfd "${T}"/minetestserver.confd minetest-server
+ fi
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+
+ if ! use dedicated ; then
+ elog
+ elog "optional dependencies:"
+ elog " games-action/minetest_game (official mod)"
+ elog
+ fi
+
+ if use server || use dedicated ; then
+ elog
+ elog "Configure your server via /etc/conf.d/minetest-server"
+ elog "The user \"minetest\" is created with /var/lib/${PN} homedir."
+ elog "Default logfile is ~/minetest-server.log"
+ elog
+ fi
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}