summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrançois-Xavier Carton <fx.carton91@gmail.com>2019-04-30 01:06:16 +0200
committerJames Le Cuirot <chewi@gentoo.org>2019-05-10 22:16:04 +0100
commit489d69eb9937af74bd248ef1574c37849de75453 (patch)
tree3739c52df326e0f3a5319162efa6581dc87ab91e /games-action/supertuxkart/files
parentdev-python/setuptools_scm: stable 3.2.0 for sparc, bug #685518 (diff)
downloadgentoo-489d69eb9937af74bd248ef1574c37849de75453.tar.gz
gentoo-489d69eb9937af74bd248ef1574c37849de75453.tar.bz2
gentoo-489d69eb9937af74bd248ef1574c37849de75453.zip
games-action/supertuxkart: bump to 1.0
- Unbundle angelscript - New deps nettle || openssl Package-Manager: Portage-2.3.62, Repoman-2.3.11 Closes: https://bugs.gentoo.org/683930 Signed-off-by: François-Xavier Carton <fx.carton91@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/11865 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-action/supertuxkart/files')
-rw-r--r--games-action/supertuxkart/files/supertuxkart-1.0-fix-buildsystem.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/games-action/supertuxkart/files/supertuxkart-1.0-fix-buildsystem.patch b/games-action/supertuxkart/files/supertuxkart-1.0-fix-buildsystem.patch
new file mode 100644
index 000000000000..23e8280a18f4
--- /dev/null
+++ b/games-action/supertuxkart/files/supertuxkart-1.0-fix-buildsystem.patch
@@ -0,0 +1,20 @@
+diff --git a/lib/irrlicht/CMakeLists.txt b/lib/irrlicht/CMakeLists.txt
+index 92a881c81..1371fdf11 100644
+--- a/lib/irrlicht/CMakeLists.txt
++++ b/lib/irrlicht/CMakeLists.txt
+@@ -96,15 +96,6 @@ endif()
+ if(WIN32)
+ add_definitions(-D_IRR_STATIC_LIB_)
+ add_definitions(-D_CRT_SECURE_NO_WARNINGS) # Shut up about unsafe stuff
+-else()
+- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -pipe -O3 -fno-exceptions -fstrict-aliasing")
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -pipe -O3 -fno-exceptions -fstrict-aliasing")
+- if(CMAKE_COMPILER_IS_GNUCC)
+- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fexpensive-optimizations")
+- endif()
+- if(CMAKE_COMPILER_IS_GNUCXX)
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fexpensive-optimizations")
+- endif()
+ endif()
+
+ if(USE_GLES2)