summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-08-04 13:38:19 -0500
committerAustin English <wizardedit@gentoo.org>2016-08-04 19:22:42 -0500
commit20a6672dbb6439e59846df3b6af4555c4f8bc1f6 (patch)
tree08a5295a08c1480b51f349b09870586cfea662ae /games-board/natch/natch-2.4-r1.ebuild
parentgames-board/mt_ncurses_client: remove deprecated games eclass (diff)
downloadgentoo-20a6672dbb6439e59846df3b6af4555c4f8bc1f6.tar.gz
gentoo-20a6672dbb6439e59846df3b6af4555c4f8bc1f6.tar.bz2
gentoo-20a6672dbb6439e59846df3b6af4555c4f8bc1f6.zip
games-board/natch: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
Diffstat (limited to 'games-board/natch/natch-2.4-r1.ebuild')
-rw-r--r--games-board/natch/natch-2.4-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/games-board/natch/natch-2.4-r1.ebuild b/games-board/natch/natch-2.4-r1.ebuild
new file mode 100644
index 000000000000..239bac11836c
--- /dev/null
+++ b/games-board/natch/natch-2.4-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils
+
+MY_P="Natch-${PV}"
+DESCRIPTION="A program to solve chess proof games"
+HOMEPAGE="http://natch.free.fr/Natch.html"
+SRC_URI="http://natch.free.fr/Natch/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses:0"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-format.patch
+)
+
+src_install() {
+ newbin src/Natch natch
+ dodoc AUTHORS ChangeLog NEWS README THANKS example.txt
+}